Jump to content
Dataton Forum

jonasf

Member
  • Content Count

    14
  • Joined

  • Last visited

About jonasf

  • Rank

Profile Information

  • Gender
    Male
  1. jonasf

    23.98 frame rates and playback in WO

    Hello, This thread might be old but I am exactly on the same boat. With most of my shows being conferences, clients and speakers would pass me last minute video files which are most of the time 25 fps and 29.97fps. 5 years ago i've done heavy testing and comparison of different file format/containers and frame rates. at that time, mpeg @60fps rendered 16mbps Constant bitrate was my optimum setting. No stutters or lags on a span of 10 projector setup. Now with HAP-Q introduced and H264 mp4 playback being stable. Is this still an important pre-requisite? At the moment, I always ask my clients to provide files in 30fps. Is watchout now capable of playing any framerate with no stutter/lag? especially if 2 video files are being played at the same cue but with different framerate. Will ofcourse do another test for this but I am curios to know your experience with this. TIA
  2. jonasf

    NDI intermittent lags/latency

    Thank you both for the suggestions. Yes I've indeed used the standby cue a few for a few shows. toggled using CTRL+B was straightforwrd. It does only work if I only have 1 camera feed cue. But for this instance, I would need to have 3 different live feed cues and a few powerpoint presentation slides. What did help me was triggering each cue as a task rather than having all of them in 1 timeline. My issue now is that, everytime I have 2 or more instances of NDI screens on a single cue, not all would play at the same time. Here's a quick test to show what I mean: After this test, I've done another approach which is to use tasks to cue each NDI Feed. It worked well and smooth but the same issue of needing to let the system cache/pre-load before I can toggle my cues. I don';t experience any latency when using the NDI Studio Monitor etc. Is there another setting within watchout that I need to adjust in order to address this issue? Thanks once again for the helpful thoughts and ideas. Getting ready for a big show next month
  3. Hello, I have managed to have 4 layers of different NDI applications within watchout. I have a live feed from an iPad Camera thru an NDI app, 2 desktop mirroring (wired connection) and 1 Live feed camera connected via hdmi onto to an NDI enabled laptop. Connections are straight-forward thru a local gigabit network. All having static IP. frame rates set to 30fps. My issue, everytime I trigger these on my main watchout timeline, all 4 screens will play but will only playback 1 at a time intermittently. playback lag are between 30 seconds to 1 min. Once all screens are playing, I have no issue with latency as I've set the latency to low for optimum performance. ie, sometimes iphone screens comes up first then a few seconds later, laptop 1 & 2 screens comes up; then sometimes vice versa. My question, how do I eliminate this lag everytime I trigger the NDI feed? otherwise this will be almost unusuable/impractical for live events. The idea is to use NDI for live feed and laptop screen mirroring without the use of capture cards and thru a wireless network ecosystem. Anything I am missing on the setup? Hoping for some guidance. Thanks in advance.
  4. jonasf

    Controlling DMX Lights using Output Tasks

    Hi All, Thanks for all the inputs and help. We are still experiencing the same issue. We have done another setup at our warehouse using another Control Server, another type of lighting fixture and another type of DMX node. We are still experiencing the same issues. Here's another video of what we are encountering. Cheers
  5. jonasf

    Controlling DMX Lights using Output Tasks

    Thanks Morgan, Your settings work within your single fixture. Our fixtures are only using 1 DMX Channel (dimmers). As per video above, the flickers do exist and a bug is still out there. This has to be fixed for everyones sake. My Watchpax is Brand New fresh from delivery so I didn't try using another unit as I don't see there was I need to. It's straight from dmxLan Node 1s to the dmx dimmers. Thanks Thomas, I believe your setup is different from mine. As mentioned above, my fixtures are only using 1 DMX channel. There is no need to partner it with other catalyst as I am only controlling light intensity and not colours. I hope dataton addresses/fixes the bug as it is still out there.
  6. jonasf

    Controlling DMX Lights using Output Tasks

    Thanks Ken, got it. Although your setup looks like it's meant for a single fixture, the principle is the same. Results also same, giving me the same issues. Say Task R, G, and B are ON. If I ONLY turn OFF B, Tasks R and G turns OFF for a while and then turns back ON. If someone is at the toilet having a shower with their lights ON, I'm sure they wouldn't want their lights to flicker OFF overtime I turn OFF my Living Room Lights. I hope we can resolve this issue. Hey Miro, Thanks for the reply. I have restarted my Watchout a few times with same results every time. I am just using 1 universe for the 102 DMX Channels I have as I don't think having multiple universe is necessary. When I control my light fixtures using my lighting desk and EasyRemote App, it works seamless with no glitches. But when I use Watchout to ON and OFF fixtures, I get these glitches. It appears like a higher DMX channel takes precedence when I think each channel should behave individually. i.e. when I click DMX 1, it shouldn't affect any other channels at all whatever state they are in. Thanks for the DMX monitor, I am also using a similar program with visualisers as shown on the above youtube link. I hope we can fix this issue as I have already handed over my project to my client. I wouldn't get a chance to test things from here onwards. Here's another video using the actual fixtures onsite. https://youtu.be/lHJxQEFKLIw Cheers, Jonas
  7. jonasf

    Controlling DMX Lights using Output Tasks

    Thanks for the reply. I had updated to 6.1.4 but I'm getting same results. For argument sake, I did a new show with just 3 dmx channels. DMX1, DMX2 and DMX3. Each dmx is on its own auxiliary timeline task. Inside is a fade in and fade out. I have a pause after the fade is completed, and when I toggle play, it moves to fade out and back to zero position. Basically, one task is an ON and OFF switch. I turn ON DMX2. I turn ON DMX1, DMX2 goes off for 2 seconds then turns back ON. It's weird way to have WATCHOUT send signals that way. My light fixtures are set to take and maintain the last action to take precedence (LTP). I did the same setup with my lighting desk and it does what I intended to do. I would use my lighting desk if it wasn't a permanent install and I because I had to use WATCHNET because the main plan is to control everything on an ipad with the custom UI etc. So in general, I will have 1 button to turn on light 1, another button for light 2 etc. I also have a button to turn ALL ON and ALL OFF. Even on the task that simply turns off all 102 channels, with the same fade in and out, they don't fade out all together but instead quickly does a chase effect that turns off DMX102 down to DMX1. It would be nice if I'm doing a light show, but for a museum, it shouts programming error.
  8. jonasf

    Controlling DMX Lights using Output Tasks

    In addition, I tried to delete some dmx channels from my output. I had it turned on manually from a lighting board. But when I click on the other tasks, the dmx channel that's not even on my program, is being turned off even without me sending out any dmx value.
  9. jonasf

    Controlling DMX Lights using Output Tasks

    I am using watchpax with watchout v6.1.3
  10. Hello, I have 102 DMX lights that I have setup to be controlled using Output Tasks. I am using dmxLAN Node 1s on Artnet. I can control all lights with no problem. My issue comes in when some groups of lights (in example, hallway lights) needs to be continuously turned on. When I play the next output task (another set of DMX channels), the current running task/lights will flicker OFF for 2 seconds before it goes on again. In a nutshell, say, DMX 1 and DMX 2 will turn off for a while when i turn on DMX 3. But DMX 3 wont turn off when I play and light that has a lower DMX value. I hope i made sense. Here's a test visualizer I have done to explain this issue further: Is this a known issue within Watchout or do i need to look at other hardwares that might be causing this issue? Hoping to get some thoughts on this. Cheers.
  11. Hi, After 3 days of intensive tests, I will conclude for now that 26 videos mp4 stresses the hardware so much that it causes watchout to drift connection, random restarts and occasional freeze frames. 26 wmv's played well at 30fps 10,000kbps CBR @ different resolutions. My specs: Intel Core i7 6800K @ 3.4GHz Quad Channel DDR4 64GB Ram AMD FirePro W7100 X99 Board S400 Sync Card 128GB Raid 0 SSD Samsung Pro Tweak List followed Windows 7 Pro Installed on Display Servers Windows 10 Installed on Production PC Setup 1 (Built-up hardware) 1 to 1 file per display, both mp4 and wmv played fine on a looping & Free running for a few hours not jerks etc. 26 files mp4 - unstable, lost network connection, freezes 26 files wmv - played on looping and free running. Jerks during transitions but catches up sync and plays loop with no problem Setup 2 (Watchpax) 1 to 1 file per display (Same result as above) 26 files mp4 - Plays the files but some video layers will freeze and needed to be refreshed (CTRL D) to make all the layers pop up and play. 26 files wmv - (Same result as above) Note: mp4s with B-Frame and without B-frame tested and rendered same results. Tested both on WO 5.5.2, 6.1.3 and 6.1.4b2 (All same results) 50 points Geometry correction on each display (no issue), I tested with and without geometry correction, same results. For now, I will limit the video layers to anything less than 10 to ensure smooth playbacks. I still stand to be corrected. Thanks for your inputs. Cheers.
  12. Thanks for the kind reply. I have rendered my clips pixel per pixel to optimize file size since i know i'd be dealing with multiple layers. Video sizes from 216x216pixels (smallest) up to 216x916pixels (largest). All clips have different sizes. I had to do this method due to the setup we have. B-Frame, I am using Adobe Media Encoder straight from After Effects export. I didn't come across any option to turn off or untick the use of B-Frames. Can you point me where or how to disable B-Frames? Memory, I am on a 32gb Dual-Channel setup. I will make it a quad-channel asap. Geometry, thanks for clarifying. I shall use 1 video next time and just do the point to point geometry correction as opposed to the 26 video files. Finally, does using Windows 10 on my production pc to communicate to windows 7 display setup as mentioned affect video layers from syncing? I had no issues controlling the show with windows 10 production pc at the moment, but if it would also possibly affect anything, then I shall also downgrade my control laptop later to Win 7. Thanks so much! I hope this also helps some people having the same scenario.
  13. Hey Thanks Ken. Understood on the crossfade, it makes sense. I actually made the crossfade as a workaround for the 2 second lags. Coz they were actually meant to be played continuously. But since I am getting sync issues with the 26 videos, I crossfade them so that the next 26 videos will get a chance to pre-roll and sync before they fade in as a next cue. For the composition distribution, separating them into 4 comps for each display came across my mind but I thought since the 4 displays are coming from 1 graphics card/cpu, that it wouldn't matter. I should've tried that previously. With this, do I conclude that I should avoid running 26 videos next time? If so, with my maxed hardware specs, what shoud be the optimum number of videos I should play with? I've also just order watchPax and will run the same show to see if there is any difference just to eliminate some questions in my head. Thanks again.
  14. Hello, I know this might be a dead thread but since the topic/issue is the same as mine, I have a few questions. I've just finished a show where I had 26 video layers different resolutions spread across 4 displays using a composition in watchout 6.1.3 I initially tried mpeg2 and h264 where both didnt even allow to me to play the clip as both display and production machines will crash everytime i play the 26 clip cue. I then used wmv 10mbps bitrate which surprisingly let me play the chunk on free running and looping with no problem. I'm fine with that until i crossfade the 26 layer comp with another 26 layer comp. I will get a few seconds of delay and unsynced video before they all catches up and play insync again. Question is, am i pushing the software with my 26 layers? I tried playing 4 layer comps but i still get the same syncing problem everytime i do the crossfade from 1 comp to the next. Any advice how to optimize my show? PC Specs: Windows 7 Pro Watchout 6.1.3 6-core processor amd firepro w7100 S400 sync card 128 ssd Samsung evo Raid-0 Ram 16GB Tweak list and codec guidelines were strictly followed. PS. I also have about 15 points of geometry correction on each display screen. Any advice or harsh comments are very much appreciated. Cheers
×