Jump to content
Dataton Forum

Search the Community

Showing results for tags 'H264'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type



Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 3 results

  1. H264 level limitation in WATCHOUT 6.2 Hi, the updated H264 decoder in WATCHOUT 6.2 has a level 5.2 limitation. It’s a third-party codec not developed by Dataton so this limitation is outside of our control. The codec update was necessary to eliminate important bugs. This level limitation shouldn’t really be a big problem for most users since most video editing tools have the same level 5.2 limitation in their encoder. In more extreme scenarios where huge and odd resolutions are required this may be a problem but there are workarounds! Each level in H.264 is basically a combination of constraints like the maximum number of luma samples per second and the maximum number of macroblocks per second. The number of luma samples equals the number pixels and a macroblock is 16x16 pixels. In level 5.2 the maximum number of pixels per second equals 530 841 600. For example: A DCI 4k footage at 60 frames per second: 4096 x 2160 x 60 = 530 841 600 luma samples/s which is exactly at the limit. A super wide video for a custom LED wall at 60 Hz: 8192 x 1024 x 60 = 503 316 480 luma samples/s is slightly below the limit. Videos with a higher luma count will be encoded using a higher level then 5.2 and will not be rendered in WATCHOUT 6.2! The easiest workaround would be to export the video as HAP or HAPQ but in some cases the large file size of HAPs causes problems when it comes to distribution of the files from a remote producer over internet. Some encoders like x264 can be forced to use a certain level despite of the luma count. You will get a bunch of warnings, but it doesn’t stop the encoding process. In WATCHOUT the decoder checks only the level of the video and if it’s lower or equal then 5.2 it will play even if it’s an 8k60 video. For example, you can use ffmpeg to transcode an 8k (7680 x [email protected]) video with a forced level: ffmpeg -i input.mp4 -c:v libx264 -refs 2 -level 5.2 -profile:v high -pix_fmt yuv420p -g 30 -bf 0 -b:v 200M output.mp4 And this video will play successfully in WATCHOUT if your CPU is powerful enough. //Miro
  2. Hello I am having trouble getting 4 MP4 video files to sync on a very large LED wall. The files are built at 50 fps because some of the content in side the content is european. We have Show Sage Built watch rack computers with the s400 sync card installed and working. All 4 files are coming off 1 machine with 4 heads. We are Emulating a 1920 by 1200 EDID at 50 hz. Watchout is connected to a Light ware 8X8 DVI router than fed DVI to 4 Image pros2 then fed to the LED Brain We have tried setting watchout to 75 fps and also custom at 50fps with no luck. I feel it is the H264 codec but would like to confirm or deny this. We have asked the agency to send us Pro res files to compare. Would HAP be a better choice? B Chaisson Playground Studios
  3. dbengali

    MP4 AVC1 support?

    Hi, I know Watchout handles h264 decoding natively, but I have been told this is not true for "AVC1" type files. It seems to be the case that Adobe Media Encoder now only encodes mp4 files as AVC1 . (Confirmed by checking codec details in VLC, which reports codec type H264-MPEG-4-AVC (part 10) (avc1) , and also in quicktime player, which reports codec type as "AVC Coding", rather than "H264") Is there indeed an issue with native support for AVC1 type H264 files in Watchout? If so, does anyone happen to know how to get current versions of Media Encoder to encode MP4 files with a different media subtype, without any restrictions on frame size? thanks
×