Jump to content
Dataton Forum
Ryanvmul

Control Dmx channels with Artnet

Recommended Posts

Hi Everybody,

 

I have some Elation colour chorus lights and I want to control them from Watchout over the Artnet protocol. But the lights doesn't react on any Watchout DMX output.

The lights are Artnet ready. I can control them from my laptop with other software, without any controller only my network, the light and my laptop. But I can't get watchout to control them.

I'm sending the DMX outputs over the same universe.

 

Does anyone got a solution for this problem?

 

Kind regards,

Ryan

Share this post


Link to post
Share on other sites

I believe you need to be Online with the production computer for DMX to work. ...

 

That is correct.

While the status window will show the effect of command changes while offline,

the actual ArtNet output is only active when online.

Share this post


Link to post
Share on other sites

If your Artnet meter (we use Artnetominator) sees the output of WATCHOUT you should check the device you want to control. Are you on the correct universe and channel? Some devices start counting from 0, others start counting from 1.

 

If you have a second programming computer you could also try to send outputs from one instance to inputs on the other instance of WATCHMAKER. 

Share this post


Link to post
Share on other sites

Hey, also check that you only have one network adapter active so you don't broadcast on network port 1 while your gear is connected to a network on port 2. On a laptop I would enter airplane mode to disable the wifi in order to force all traffic through the wired network adapter.

 

The subnet mask is used to narrow down the broadcast range. In most setups the subnet mask is 255.255.255.0 which allows you to broadcast to class C subnet. As example, if your IP is 192.168.0.12 you can broadcast to all 192.168.0.xxx addresses (255 destinations). But if your light gear is located in a different subnet like 192.168.1.xxx the artNet commands will not reach those devices. You can modify the subnet mask to 255.255.254.0 in order to reach both subets (192.168.0 and 192.168.1). Double check your ip addresses and network settings.

Share this post


Link to post
Share on other sites

I actually have kind of the same problem.

 

Artnet is playing from another software but not from Watchout... when I record Artnet and also patch the recorded Channels as Inputs (just to check if the recording worked)  I can see that I recorded Artnet but then it's not going out to the lights. Yes I am online, yes the universes and channels are correct and yes I had problems multiple times on several occasions and I always had to work around this problem quite time consuming.

 

... yes I know of the counting problems of the universes. and I also had the problem while converting the whole channels to DMX (DP8000 and Enttec) or just staying in artnet.

 

Just maybe there is something to

Share this post


Link to post
Share on other sites

I'm working quite often with watchout and artnet and I can understand that this can be very frustrating. Most of the pitfalls have been named already.

- You have to be online to send artnet from the production computer

- You shouldn't have more than one active network interface

- Your production computer need to have a network route to your artnet receiver. If you don't have a router and aren't a network pro that usually means that both devices have to be in the same network subnet (within a subnet network packets are transmitted without a router)

- Some artnet receivers are only listening to artnet traffic on ip range 2.x.x.x or 10.x.x.x. Some even fool you because you can set up a different administration ip adress and they still only listen to the specified artnet adresses. The most compatible range is 2.x.x.x with a netmask of 255.0.0.0

- Artnet is (most often still) a UDP broadcast protocol. So there is no destination IP, to select a receiver you need a network port number which is called universe number in artnet. That is a little tricky point because different devices generate the port number in different ways. In watchout the port number is the same as the universe number and it is entered as a decimal number. In other products you often find terms like network, subnet and universe which relate to the original artnet specification. They don't have to do with IP adresses, they are just the original artnet way of generating the port number and sometimes they have to be entered in hexadecimal notation. The easiest way is to set everything to the lowest possible value. As already mentioned this is the next pitfall as some devices start at 0 and some at 1. So be prepared to juggle a little bit with a +-1 offset.

- Make sure you only have one device transmitting a specific universe. If you are not sure start with only one transmitting device at all. If more than one device is transmitting to the same universe this can lead to an unpredictable result.

- Most artnetmeter and artnet test programs are not suited well to troubleshoot artnet problems because they just show the values of an artnet universe and don't give you underlying network information. If you are a little nerdy you can try Ethereal, if you prefer a higher level use Artnetominator.

 

Generally I would whish that the artnet got a few more options from Dataton. In my opinion it would help a lot if I could have more network interfaces and could chose one or more for the display control, one or more for artnet, one or more for remote tcp or udp control...

 

Dorian

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×