Jump to content
Dataton Forum
ABish

Watchout 6.2 Mask/Edge Blend Issues

Recommended Posts

Hello,

I was prepping a show using Watchout 6.2 yesterday and ran into an error when testing the system where pixels that should be masked or edge-blended are being rendered as black pixels.

 

The issue first presented itself when I was testing the outputs and had two 1920x1080 outputs stacked on top of each other in the Stage Window. This led to the outputs (identical Samsung TVs) rendering 20 or so vertical lines of pixels on the left correctly, and the rest as black. When I moved the outputs so they were overlapping, but not perfectly stacked, the overlapping pixels were rendered as black, and the rest were rendered correctly. I turned off the global edge blending on one output and was able to see all pixels rendered correctly. I then added a gradient mask to that display, and those pixels affected by the mask all rendered as black.

I know it's a different engine, but I feel that it's worth noting that the Opacity tween works as expected.

 

Does this sound like an issue any of you have run into before?

 

Thanks!

Share this post


Link to post
Share on other sites

System specs:

Intel Core i7-4930K @ 3.4GHz Processor

16 GB RAM

Windows Embedded 8.1 Industry Pro 64 Bit OS

AMD FirePro W8100 graphics card

 

Let me know if you need additional specs.

Share this post


Link to post
Share on other sites

Watchout applies edge blending when Displays overlap on the same Stage Tier. If you move the stacked/overlapping Displays to another Tier things should probably behave as you expect.

Share this post


Link to post
Share on other sites

Putting each display on different tiers allows all pixels to be rendered, yes, but the show I'm working on needs edge blending capabilities. Currently, in 6.2, anything that should be blended is just black.

 

Since we've rolled back and solved the issue, I won't be able to troubleshoot the issue anymore, so I guess think of this thread now as a bug report than a request for assistance? I'm happy to clarify the issue further if anyone needs.

 

Thanks!

Share this post


Link to post
Share on other sites

Hi, this issue is related to a bug in some rare cases when using multi-sampling anti-aliasing. This is solved in 6.2.1 which will be out soon. A workaround is to turn on and off the AA-settings in WATCHOUT 6.2. Sorry for any inconvenience.  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×