Jump to content
Dataton Forum
RyanR

Choppy Playback on ShowServer XHD R4

Recommended Posts

I have choppy playback on my ShowServer XHD R4 running 6.2-6.3 (Just updated to 6.3.1 from 6.2.1 and the issue is still present). Sometimes its a frame or two every couple of seconds, once in a blue moon it runs seamless, other times it jumps / skips a ton of frames multiple times / second. I'm trying to run two concurrent 3840x1493 29.97p clips. I have tried ProRes 422,  LT, Proxy, HAP-Q (2 & 3 chunk), and also 1080 x 7XX versions of each flavor. There are no effects outside of geometry and edge blending applied. Even deleting a layer and playing only one clip results in the same issue. I have tried 60hz, 59.98hz, 30hz, 29.97hz settings in Watchout,

The display computer should be up to the task and then some. 10 core i9 7900x, Top of the line AMD GPU, Samsung 960 1.9TB SSD. The performance self diagnostic is 7.8/7.9, so its blazing fast and there should be NO REASON that this thing skips from hardware limitations. 

Show Specifications: 

  • 2x 3840x1493 videos playing simultaneously
  • 3 outputs/projectors
    • 2x 1920x1200 Panasonic RZ12k that are blending one of the video files together
    • 1x 3840x2160 Panasonic RZ32k 
  • Each clip is approx 50 minutes long
  • No effects, color, anything applied to any clips.
  • Playback is using external timecode, but skipping occurs regardless of chasing SMTPE or not. 

What am I doing wrong or where should I look?

Share this post


Link to post
Share on other sites

Hello Ryan,

This issue is often when you mix output frequencies (which should be the same).

My guess is your 1920x1200 is at 59.94 while your 3840x2160 is 60.

An easy try is to switch to 1920x1080 which is normally 60 also and it should play fine...

Best,

Benoit

Share this post


Link to post
Share on other sites

50min long? Might wanna try chopping them in 2 or 4 parts. How big is one file? I wonder what this does to buffer or whatever... 

Or at least try the same with a few short test files (5 minutes each or so)

Share this post


Link to post
Share on other sites
16 hours ago, Benoit said:

Hello Ryan,

This issue is often when you mix output frequencies (which should be the same).

My guess is your 1920x1200 is at 59.94 while your 3840x2160 is 60.

An easy try is to switch to 1920x1080 which is normally 60 also and it should play fine...

Best,

Benoit

Thanks Benoit, I will try this on Friday and report back. I think you're on to something. 

 

11 hours ago, Walter said:

50min long? Might wanna try chopping them in 2 or 4 parts. How big is one file? I wonder what this does to buffer or whatever... 

Or at least try the same with a few short test files (5 minutes each or so)

I will tell the editor to give me some exports in chunks. 

 

Really appreciate the advice everyone!

Share this post


Link to post
Share on other sites

A lot (if not all) AMD drivers from 2018 have had performance issues of various sorts. I would advice you to test with the drivers from 2017 q4.1 and see if that makes a difference. 

 

/Erik 

 

Share this post


Link to post
Share on other sites

Ok, so switched two projectors to 1920x1080 59hz, and the 4k projector is at 59hz. It helped with the stuttering, but there are still a few frames that it skips, so it didn't solve it 100%.

I have tried 29.97hz out of watchout, which made a few faster motion parts sharper, but it still skips. When I do 59hz output, it still skips, and additionally the fast motion parts are blurry (and I have motion blur turned off on clips). 1080 vs 4k doesn't make a difference. 

Also, the AMD driver is 2017 q4.

Share this post


Link to post
Share on other sites
On 11/21/2018 at 2:03 AM, RyanR said:

The display computer should be up to the task and then some. 10 core i9 7900x, Top of the line AMD GPU, Samsung 960 1.9TB SSD. 

Hi,

When looking at the specs of your computer, I have some questions about your SSD? Is it the EVO or the PRO version of the M.2 960? The PRO would be the one to choose here. Is Windows residing on the same SSD or on a separate SSD/HDD? I do not know which mainboard you're using, where does the SSD sit? Flat on the mainboard? Is there a good airflow around the SSD?

Those M.2 SSDs tend to heat up a lot when they deliver video data. This even more if you use large and less compressed codecs. ProRes files are usually rather huge and the same goes for HAP-Q. Out of those I would rather go for HAP-Q and not for ProRes. ProRes is a codec designed for post-production and not really meant for playback. You could also try H264/MP4 if encoded following the guidelines found in various threads in this forum.

When the SSD heats up it will start to throttle, means it's performance will go down.

We have some servers using the 960 PRO M.2 SSD but we are now using PCIe slot carriers with a big passive heat sink and we have an extra cooler (vent) blowing air onto it. Since then we did not see overheating anymore.

Benoit's hint of cutting the large video into smaller portions might help. In fact it is not really the same when it comes to performance whether you use a 4K video or 4x fullHD files. Using 4 files will help since then it would make use of more cores instead of squeezing the whole video through one core. Of course, using chunks does the same in a way, but this only works with HAP codecs.

Hope it helps

Rainer

 

Share this post


Link to post
Share on other sites

Ryan,

If the issue persists, contact us directly at [email protected]  Please include the serial number of the server.

Regarding the HAP files, on that server, you should be encoding using at least 4 chunks and as many as 8.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×