Jump to content
Dataton Forum
matkeane

Watchout 6.3.1 Bug Copying Tweens

Recommended Posts

In Watchmaker version 6.3.1, I'm no longer able to copy/paste certain Tween FX between cues. After applying Hue & Saturation to one cue, and selecting the Tween track in the timeline sidebar, the 'copy' option is greyed out in the menu and the keyboard shortcut no longer works. I just opened the same project in 6.2.2 and 6.3.1 and I can copy/paste tween tracks as expected in 6.2.2. I haven't tried all the available tween effects, but Contrast & Brightness suffers from the same bug, while Opacity tweens copy OK. I didn't notice anything in the release notes about changes and, suffice to say that, on a project where the client wants colour correction applied to multiple cues, this regression is a real pain.

Share this post


Link to post
Share on other sites

I just tried it out and had no problems with copy/paste. Did not try all of the tweens but Hue & Saturation and Contrast & Brightness worked fine for me.
Are you still experiencing this issue?

Share this post


Link to post
Share on other sites

Could it be that this is actually on of those Windows 10 bugs? Had copy/paste/move issues -it suddenly stopped working) for some months in Exlorer, only restarting the Explorer process(es) would help. I even made a shortcut (.bat) for it on the desktop.

Since about two weeks or so this seems to be gone. After some win-updates.

Share this post


Link to post
Share on other sites

I think I have narrowed this down... I first encountered it during a show just before Christmas, using Win7 Pro producer machines, and was able to reproduce it at home (also on Win7 Pro production) in both the show file and a new test file.

I've just started a new test project and I can happily copy-paste opacity and scale tweens but not hue-and-saturation (copy option is greyed out in the menu)... that is, until I add a keyframe. Once there is a keyframe (for any of the hue/saturation/gain values), the 'copy' option is available in the menu. Same applies for other tweens.

Why do I want to copy a tween with no values set? Because I'm using it with a formula linked to a generic input, so that I can control the hue/saturation of several clips at the same time.

It looks like adding an initial keyframe with a default value allows me to set up a formula and then paste it to another clip, but it seems like copy-pasting of tweens is not always consistent though - opacity, scale and z-rotation tweens can be copied without keyframes, but not other tween effects. Scale and z-rotation I can almost understand, as they can be set in the UI without actually adding a keyframe, but I can copy an empty (no keyframes or formula) opacity tween track... Perhaps only tween tracks with a single property value can be copied without keyframes?

So I guess it's not a bug, just user error (would be nice if copy-paste behaviour were consistent though).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×