Jump to content
Dataton Forum
Sign in to follow this  
jgaylor

TCP Control-TimeLine Status

Recommended Posts

Using a Crestron system, I am trying to talk to a Watchout System over IP.  More specific I am trying to get the status of individual timelines, (Paused, Stopped, etc…).. 

 

I received this from a support tech with Dataton.

 

I also have a document with what a response should look like.

 

Example 1:

 

Your WATCHOUT show is named "TestShow" and the auxiliary timeline inside the show is named "Movie1" and you want to know the status continuously.

To achieve this you send the following strings (in bold to WATCHOUT display computer by TCP/IP or UDP/IP to port 3039.

Note, every line should be ended with a carriage return character (0x0D):

 

authenticate 1

load "TestShow"

 

(you now need to wait some time for the cluster to build up 1-5 sec)

 

getStatus 1 "TaskList:mItemList:mItems:TimelineTask \"Movie1\""

 

(Now you will get a periodic update of the status of the Movie1 timeline.)

 

(To reset the status you simply send the same string but with the "turn-off" parameter)

 

getStatus 0 "TaskList:mItemList:mItems:TimelineTask \"Movie1\""

 

 

Example 2:

 

Your WATCHOUT show is named "TestShow" but you have already sent one load command so the show is already loaded. 

The auxiliary timeline inside the show is named "My Super Show" and you want to know a "one-shot" of the status.

To achieve this you send the following strings to WATCHOUT display computer.

Note, every line should be ended with a carriage return character (0x0D):

 

getStatus 2 "TaskList:mItemList:mItems:TimelineTask \"My Super Show\""

 

 

I have tried this to no avail.

 

Additional Notes

 

This is what I am getting back 

 
Error 6 6 "Command: getStatus; Invalid/unexpected/damaged data: getStatus 1 \"TaskList:mItemList:mItems:TimelineTask \\x22Timeline1\\x22\""\x0D\x0A
 
 
I copied it directly from the email. But replaced my timeline name.
 
getStatus 1 "TaskList:mItemList:mItems:TimelineTask \"Timeline1\""\x0D
 
 
A Ping command gives me this
 
Ready "5.5.1" "WATCHPOINT" "Windows" true\x0D\x0A
 
 
Any thoughts?
 

 

 

I copied it directly from the email. But replaced my timeline name.

 

getStatus 1 "TaskList:mItemList:mItems:TimelineTask \"Movie1\""\x0D

 

 

A Ping command gives me this

 

Ready "5.5.1" "WATCHPOINT" "Windows" true\x0D\x0A

 

 

Any thoughts?

 

What a response should look like.

 

Example 3:

Note the quoted auxliary timeline name, which must use escaped double-quotes since it’s

embedded in the property path string.

getStatus 1 "TaskList:mItemList:mItems:TimelineTask \"Timeline 1"\"

:

Status ”TaskList:mItemList:mItems:TimelineTask \"Timeline 1\"” 2 12114 94553321

:

Status ”TaskList:mItemList:mItems:TimelineTask \"Timeline 1\"” 2 17210 94558417

 

 

Share this post


Link to post
Share on other sites

Have you tried sending the command using a telnet client? If that works, the control system is probably doing something funky to your embedded escape sequences.

 

Mike

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...