Jump to content
Dataton Forum
TomT

Need some help with DMX

Recommended Posts

Hello to you,

 

I need some help to get DMX commands out of Watchout.

 

My System is :

Windows 7 (tweaked), Watchout 6.1.6, Ip-Range 10.0.0.xxx,

Artnet to DMX converter is a DMX4all Stage-Profi 1.1, Set to 10.0.0.99, Universe 1.

Watchout / Preferences / Control / DMX-Universe in = 0, out = 1.

 

Drivers / Software of the StageProfi 1.1 is installed on WO-Control and Display PC.

 

While the StageProfiis working fine with it´s native Software, I can´t get any Results from Watchout....

 

The LED-Spot I´m using for testing h

Share this post


Link to post
Share on other sites

Hi TomT,

 

I am not familiar with the DMX4all Stage-Profi 1.1 but if Watchout PC (either Prodn or Display) sees it in the Network Connections, then it should work.

 

With LED lights, I've found that usually Ch 1 is the Intensity, and Channels 2,3,4 are the RGB channels. If so, to get it to work, it is 1+2, 1+3 or 1+4 for each color, or 1+2+3+4 to get all RGB colors to work, i.e. Ch 1 must always be on. Some use certain values of Ch 1 to flash at different rates instead, such that Ch 1 @value 1-55 flashes/strobes the LEDs, @value 56-100, it stops the strobe and sets the intensity. Check the manual of your LED spot on the DMX channels.

 

Additionally, for other LEDs, I've seen a Ch 10 which sets the on/off of DMX usage! So it depends on the LED manufacturer.

 

Good luck!

Thomas Leong

Share this post


Link to post
Share on other sites

...I think the artnet commands are only sent from the display pc.

 

Martin

 

ArtNet and IP are sent from the cluster master.

When Production is present, it is the cluster master, and it sends the ArtNet and IP commands.

In cluster mode, the ArtNet and IP are indeed sent from the (cluster master) display PC.

 

(And this why whenever you switch from production mode to cluster mode

you must send the load command again to the cluster master

even if the show is already loaded by production.

 

The load command establishes the cluster master,

until that time, the entity that last loaded the show (production)

remains the master, even after it is removed.

You must explicitly re-establish a display computer as master

after leaving production to run in cluster mode.

 

and yes, ArtNet and IP are only transmitted when online.

when offline, the output window will display the effect of the command,

but nothing will be transmitted.

Share this post


Link to post
Share on other sites

First, thanks to all your answers!

Unfortunately I press the wrong key the post was sent and I couldn´t go on with my description.

So I had to wait for the admin to aprove my post .....

In between I had a Job to finish and couldn´t find any time for further response.

 

My first Problem was not to get any result on my DMX-Spots and I found out, when every fixture in the lighting world is working on Universe1, Watchout doesn´t !

I know Watchout is sending DMX from Production-PC, but..... in Preferences I have to set the output to Universe 0 to reach all the other devices In Universe 1 !!!

Bug?

 

Next thing is, DMX is working fine when noch Display-PC is online...means when only using DMX-Outputs everything is working fine.

When adding a DisplayPC to the stage and pressing CTRL-L the Display is working fine but no result on DMX.

The only workaround is: 

Stopping Watchout on Display-PC, going online with Control-PC, then starting Watchout on the Display-PC and pressing CTRL-D ! Not CTRL-L double time, else DMX is not working any more.

Unfortunately the Display_PC are stuttering when playing video (when using the workaround)  :(

Bug?

 

Maybe someone can checkout if I´m right. (WO 6.1.6)

 

Thanks in advance!

Share this post


Link to post
Share on other sites

Hi TomT,

 

I tested Artnet/DMX on a WATCHPAX 4 (6.1.5) and a small display server (6.1.6) using a KISSBOX DMX-512. All works as expected.

 

I could send DMX using a production notebook and playing a video on a display computer at the same time. No stutter on the video. Then I went offline and controlled the display computer through telnet to start the same timeline. Now the display computer sent Artnet and my led lamp and the video did the same as before.

 

As jfk wrote, you will need to send authenticate 1 first and then load "showname" to make the display computer take over control.

 

 

Rainer Beddig

Share this post


Link to post
Share on other sites

Hi Rainer, 

thanks for your comment!

While I´m quite busy in the moment I can´t go on with more tests, but at the end of the week I will have some time.

Just to make it clear, I used a (all tweaked) Laptop with 6.1.6 as Production and two PC with I7 and W8100 as Display.

Production was always in use so there was no need to control DMx from the displays.

 

Did you checked out which Universe you had to use in the preferences ?

I had to set Universe = 0 for DMX-out in Watchout while my LED-Lamp (and a little lighting-mixer) worked with Universe 1  !

 

As soon as I have time for a second check I´ll come back here with results.

 

BR Thomas

Share this post


Link to post
Share on other sites

Hi Thomas,

 

I used a production notebook with Win7 and basic tweaking only (just some important things turned off) and a small fully tweaked i7 server as well as a WATCHPAX 4 (still 6.1.5). I had no issues sending DMX and I use this feature always in our Academy trainings.

 

The universe numbering can be a bit confusing. WATCHOUT and some other products count from 0...511 while some other manufacturers count from 1...512. The 0...511 approach is the one used by programmers and actually reflects the Art-Net standard. Art-Net counts from 0.

 

The issue might also be the network setting itself.

 

I'm not following the standard by using Art-Net in our normal class-C network 192.168.x.x / 255.255.255.0. This works when I send Art-Net to our KISSBOX converter and then into a DMX network. When you want to talk to a "real" Art-Net device, e.g. some lighting controllers, you would most probably have to use the class-A network addressing of the ArtNet standard, which is either 2.x.x.x or 10.x.x.x /255.0.0.0

 

But, the use of class-A addressing is only allowed within a closed network. It is important to make sure that Art-Net data is not routed onto the Internet.

 

See http://www.artisticlicence.com/WebSiteMaster/User%20Guides/art-net.pdf  p.8 for more details.

 

A nice tool to analyse Art-Net is "ArtNetominator". We use this from time to time to check whether we are sending on the expected universe or not.

 

BR

 

Rainer

Share this post


Link to post
Share on other sites

 ..... in Preferences I have to set the output to Universe 0 to reach all the other devices In Universe 1 !!!

Bug?...

 

You state that as if it is some kind of a surprise - it is a common issue.

The "0 is a valid integer" disagreement is as old as the MIDI and DMX standards.

When the raw hex value 0 is evaluated,

some will call it the "first" value (CH 1, universe 1, etc)

and some will call it 0. 

Apparently neither is incorrect. ymmv

sussing that out (and expecting it) is a common part of ringing out a system.

Share this post


Link to post
Share on other sites

Thanks to Rainer and JFK for your help.

 

I know about the Network classifications, normally I only use closed A-Networks with 10.x.x.x.

And I know about the different ways to start counting from 0 or 1.

But whats really new for me is that counting from 0 is also used in the DMX-world, I´ve never seen that before.

So you´re right jfk, it was a kind of surprise for me :)

 

But I´m not very experienced with lighting and its standards, so it took a while to find out that Universe 1 is 0 in Watchout (Artnet?).

 

I tried to analyse my network with the ArtNetominator, but I couldn´t get any results.

So I changed the preferences of DMX out and in to 0, created an in- and an output to see if Watchout is sending an artnet signal.

This worked for me.

 

Again, thank you all for your help and your hints, next week I will have some time to reinstall my clean images on Production and Display, then I will check out what went wrong.

 

I will let you know then.....

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...