Jump to content
Dataton Forum
jaygrovr

LTC chasing timecode isssues

Recommended Posts

Hey guys.  I have a display cluster that is being controlled by medialon.  We are having it chase timecode from medialon.  Medialon sends a load show command with a timecode mode command.  We are having issues of 1 out of about 20 timecode starts, it doesnt chase correctly.  We are running 6.1.6 since none of the new versions seemed to work right with timecode.  We have other devices listening to timecode and they work fine.  I have used the watchout timecode test tool and my levels are set correclty (about 75% of the bargraph).  

 

When the problem occurs, the playback jumps all over the place as soon as it starts chasing.  Rebooting the cluster machine seems to fix the issue. Until another time period where it happens again.  These machines can be left on 24/7 waiting for timecode,correct?

 

thanks

Jason

Share this post


Link to post
Share on other sites

Hi,

If the timeline length is shorter than the timecode received, you will see strange timecode values and flickering in images.

I would not turn the timecode listening mode on and off all the time as long as you have control over the timecode itself (Medialon). It's recommended to not only turn the timecode listening mode on but to also tell WATCHOUT what sort of timecode it should expect (25fps, 30fps,...)

You should also allow for a little pre-roll since timecode readers need to analyze the complete timecode string first to adjust the correct position. This hasn't changed much since the times of tape based media.

Last but not least, the timecode value is only half of the story. If in doubt, you should check the signal with a scope. LTC is a rectangular signal and should look like rectangles on a scope. Some audio devices have problems with rectangular signals and if the shoulders look too much like a sine-wave or even worse, the timecode reader has problems to synchronize to it, even if the signal strength is fine. 

Share this post


Link to post
Share on other sites

Ok, the shows we are running are about 3 minutes long.  The timeline length?  So if timecode runs longer than the length of the timeline, errors will occur?  I think the default lengths that I saw are over an hour, but I will make sure they are correct.

We are doing about 10 seconds of pre-roll, but this issue shows up almost immediately.  This doesnt happen very often, and its hard to replicate.

Also, all the 8-10 shows we run medialon does the same exact set of commands, sets timecodemode to on and sets the type of timecode.

This issue only comes up about every 24 hours, since the cluster machine is on all the time, it just sits there waiting for the next command.  Jim Kellner mentioned that since out showfile has both the main and backup cluster machine in the file (on different stages), that the master cluster is looking for the slave machine.  I find it hard to beleive that the master will have problems playing back if the slave is not present.

Timecode is being distributed by sr-115 distripalyzers, and we have other systems listening to the same timecode, so I know its not distribution or generation.  Also, I used the timecode test tool and it shows good level and clean code.  I set my level to be about 70% of the bar.

 

I am looking for mistakes that I may have made that would cause timecode to not work properly.  My client is getting more and more upset as I have never seen this issue before.

Share this post


Link to post
Share on other sites

Could this issue come from the wrong type of timecode selected on timecode mode?  I would suspect our sync with lips would not be correct if it was set wrong.  I would also assume that this issue would occur on every occurance timecode was to be chased, correct?

Does the timecode test tool show the type of timecode correctly, or you just have to know?

Share this post


Link to post
Share on other sites

Is there an approved list of audio interfaces that use USB for timecode input?  Or what have people used for this before and not had issues on 6.1.6.  I hear the WDM driver is a nightmare.  I am getting a behringer UMC22.  Jim Kellner said that behringer has been known to work, but there is no certified/approved list of hardware.  I would even accept just a list of products that have been known to work.

 

thanks

Share this post


Link to post
Share on other sites

Hello,

Watchout is not able to detect all types of timecode and sometime it guess wrong. Specially between the different SMPTE variant. I think it's SMPTE-30 that is not technically possible to differentiate from SMPTE-NDF, anyway, putting the right type of timecode always help.

Is it the Medialon that generate the audio timecode? Because, if yes, you can also use a Medialon timeline with positrack and it will work the same using only IP.

Best,

Benoit

Share this post


Link to post
Share on other sites

So the controlling system, medialon is not really the issue here.  Its really just watchout not chasing timecode correctly.  Positrack or not, we are not using that function, and we just want watchout to act as a playback deck, while medialon tells it which show to load, and watchout waits for timecode.

We are installing a behringer umc22 audio interface today, and getting rid of the balanced to unbalanced adapter cable.  Some people feel that some interference on the unbalanced audio line to cause issues.  I really hope this will solve the problem.  I am not looking forward to getting the driver to work.  If anyone has any experience on what should be done to get the interface working on 6.1.6, it would be appreciated.  

 

Thanks

Jason

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...