Jump to content
Dataton Forum

Recommended Posts

Hi,

 

We're looking for a way to control (shutter on/off, etc.) our projectors from the Watchout production pc. Is this possible with the PJLink protocol? I've tried it by adding a string cue on the timeline with the PJLink command, but I can't seem to get it to work. Tried it with a PJLink test program and it works flawlessly. Is it possible?

 

Thanks!

Share this post


Link to post
Share on other sites

I've solved it by using this document: http://pjlink.jbmia.or.jp/english/data/PJLink Specifications100.pdf which describes which values I can use (and checked the projector manual for the right possibilities). I can now for example power down a Panasonic PT-D5700 by using a string cue which contains the value %1POWR 0$0D. I've used the output window to make a connection to the projector: I've filled in the correct IP-adress and port (for the D5700 I had to use port 4352 over TCP).

Share this post


Link to post
Share on other sites

Hi all,

I'm going to set-up a show in which I need to send some remote controls to Panasonic projectors (PT-DZ6710 and PT-DZ110X ).

Both use the same control commands and the same protocol.

I set a TCP output, set the IP and port and set the command string (for example shutter On is "00OSH:1$0D").

The first time i send this command, it seems the projector don't receive it, the second time watchout shows a warning that says that the command was not sent and the 3rd time it works.

So, every command I want to send, I have to send it 3 times: the 1st one doesn't work at all, the 2nd always displays a warning and the 3rd always work.

 

It's a strange thing, isn't it?

Maybe I'm doing something wrong.

Panasonic, barco and Christie are probably the widely used projectors, so maybe someone can give me a hint...

 

Thanks,

Luca.

Share this post


Link to post
Share on other sites

I red that topic but the command i found there doesn't work:

with PT-DZ6710 and PT-DZ110X the communication is on port 1024 and not 4352.

The syntax for a power On is "00pon" and for example for the shutter to go on is "00osh:1" then an "enter" ($0D watchout hexadecimal code).

 

If I create a TCP/IP output communication, with the correct IP and Port and then create a command

 

00osh:1$0D

 

I have to "play" it 3 times before getting it work. at the 3rd time i play that command and only at every 3rd time, it works.

 

I tried to control another device: a power IP interruptor which can be controlled through web links (so I used GET http command) and even this device, can be controlled by sendig 3 times the same command...

 

edit: I don't know what the "%1" prefix used in the command on the thread linked above means, but in my situation, if i place the %1 code before my command, it doesn't work at all

Share this post


Link to post
Share on other sites

Off-hand, if the command(s) you are sending works, albeit on the 3rd try, then the command is essentially correct.

It is then likely that the port or TCP/IP link is at fault the first two times, either from the Panasonic end, or the Watchout PC end, or at the router/switcher/hub.

Difficult to narrow down unless you can monitor at each stop the in-coming signal.

 

The workaround at this point, without wasting more time on it, is to put 3 instances of each command in Watchout's Timeline, staggered at say, 0.1 - 0.5seconds apart. WO will then send the command 3 times at those intervals, and the 3rd should work.

Share this post


Link to post
Share on other sites

I've downloaded and browsed through the manuals for the PT-DZ6710 and PT-DZ110X. The latter is more detailed compared to the manual for the DZ6710.

Referring to page 95 of the DZ-110XE manual for the Network Setup, it appears that there are 3 ways to control the projector: Web, PJ-Link, and RS-232 Command.

 

Shot in the dark:

Since you said you have to send the command 3 times, and it always responds on the 3rd time, perhaps the projector is cycling through its protocol for each send it receives - Web first, then PJ-Link, then RS-232 Command - and finds that the 3rd protocol corresponds with your commands, then responds to it. So I think you have to navigate to this Network Settings menu, and SET the protocol to the third RS232 Command, Save, then try a send from Watchout.

 

The other forum post that I referred you to, used PJ-Link because he mentioned that he used %... in one of his commands. From the PJ-Link specifications 100.pdf, it says "All PJLINK command lines, without exception, start with ‘%’. If it has not worked for you, I reckon you have not selected PJ-Link as the protocol to use for the projector.

Share this post


Link to post
Share on other sites

Yep, according to the DZ-110XE manual pages 119-120, you have been using RS232 rather than PJ-Link since you mention 00pon for power on, and 00osh:1 for shutter execute.

 

As I said earlier, most times it is syntax error on the user part. For example, I don't know what the 00 is before pon, and also before osh:1 (Note it is the letter o, not numeral 0, in the command osh). According to the Basic Format given on page 119, it should be -

02ZZ;PON03$0D (read as: zero 3ZZ semi-colon;capital PON with letter O, not number 0 followed by zero 3 then Watchout's requirement for the carriage return $0D as in zero D)

but since the start and end bytes are hex codes and output from Watchout requires that hex be preceded with a $ sign, I think it should actually be -

$02ZZ;PON$03$0D

 

Some serials are case sensitive, so I've used capitals where so given in the manual.

The only doubt I have in the above is the Projector ID syntax. I have used the string ZZ to identify ALL projectors. I could be wrong (and without a projector to test, I'm only guessing).

 

For shutter control, try -

02ZZ;OSH:103$0D (where value 1 is for shutter execute, and value 0 is for shutter end (I presume on and off, respectively.)

or

$02ZZ;OSH:1$03$0D

 

Note: No command can be sent or received for 60 secs when the projector lamps have just started.

 

As an after-thought, perhaps the PJLink protocol is easier to use as the PJLink Specification 100.pdf document gives clear examples of the syntax to use for every command.

Share this post


Link to post
Share on other sites

Panasonic PJLink - projector control

 

Just had to work with a pair of Panasonic PT-DW6300 projectors.

Couple of notes.

 

If necessary, remove administrator password.

 

The TCP connection port is fixed at 4352.

There is a command control port setting, which confused me,

but that port setting is not related to PJLink.

It is necesary to enable PJLink control.

 

Panaosonic-PT_DW6300-net_permission.png

The Command port setting is not related to PJLink and does not matter,

PJLink port is fixed at 4352.

 

Of course, the network settings need to be in the same subnet as the WATCHOUT system.

Typically, the gateway setting should be left blank.

Panaosonic-PT_DW6300-net_settings.png

 

Each projector in a system must have a unique IP address,

and that is the only form of addressing required for PJLink.

 

Strings we used successfully.

 

Shutter close (picture mute)

%1AVMT 31$0D

 

Shutter open

%1AVMT 30$0D

 

DVI input select

%1INPT 32$0D

 
VGA input select
%1INPT 12$0D

Share this post


Link to post
Share on other sites

So I'm about at my wits end on this problem. I'm currently running a Panasonic DZ21KU projector. I've been trying to get Watchout to accept Shutter commands via RS232 and/or TCP but both are not working. I've run a COM Port Test program and have sent the shutter commands successfully from the display computer to the Projector it's attached to, and I've also been able to log into the Projector from a browser and send commands from the Panasonic Interface via Cat5 so I know the Projector, the adapter, and the IP all are correct. Current version of Watchout is 5.3.1 on all PCs. But still, nothing when I send it through Watchout. Here's a breakdown of what I'm doing.

 

RS232:

Confirmed I'm in COM1

Verified my USB to Serial Drivers

Baud Rate is 9600, No Parity, All other settings match Projector from the Projector Menu

Tried commands for Shutter IN:

[sTX] OSH:1 [ETX]$0D

{STX} OSH:1 {ETX}$0D

02 OSH:1 03 $0D

/02 OSH:1 /03 $0D

All the above without spaces

None of these work in a Task or Composition Timeline.

Tried another display computer, no luck.

 

For LAN:

Disabled the admin password

Set Port to 4352

Set IP to 192.168.0.30 in both Watchout and on the Projector and clicked the Save Settings button on the Projector

Gateway set to 192.168.0.1

No DHNS

RJ Link is Enabled

Tried UDP and TCP

Pinged the computers from the Projector Browser software successfully

Using the command %1AVMT 31%0D to Shutter

 

Anyone have an idea?

 

Share this post


Link to post
Share on other sites

....Pinged the computers from the Projector Browser software successfully

Using the command %1AVMT 31%0D to Shutter

Anyone have an idea?

 

That command string is incorrect. Should be:

%1AVMT 31$0D

 

Projector browser software is not PJLink BTW.

While that confirms the connection, 

it does not confirm the projector is properly setup for PJLink operation.

Share this post


Link to post
Share on other sites

Hello everyone,

I am trying to send a video mute on/off and a power down and up singnal to my Panasonic projector and I don't know what the serial code is. Does anyone know where I could find this informantion.

Thanks,

B

Share this post


Link to post
Share on other sites

So I'm about at my wits end on this problem. I'm currently running a Panasonic DZ21KU projector. I've been trying to get Watchout to accept Shutter commands via RS232 and/or TCP but both are not working. I've run a COM Port Test program and have sent the shutter commands successfully from the display computer to the Projector it's attached to, and I've also been able to log into the Projector from a browser and send commands from the Panasonic Interface via Cat5 so I know the Projector, the adapter, and the IP all are correct. Current version of Watchout is 5.3.1 on all PCs. But still, nothing when I send it through Watchout. Here's a breakdown of what I'm doing.

 

RS232:

Confirmed I'm in COM1

Verified my USB to Serial Drivers

Baud Rate is 9600, No Parity, All other settings match Projector from the Projector Menu

Tried commands for Shutter IN:

[sTX] OSH:1 [ETX]$0D

{STX} OSH:1 {ETX}$0D

02 OSH:1 03 $0D

/02 OSH:1 /03 $0D

All the above without spaces

None of these work in a Task or Composition Timeline.

Tried another display computer, no luck.

...

Anyone have an idea?

 

Start of transmission aka STX = $02      End of transmission aka ETX = $03

 

So the above command string should look like this in WATCHOUT ...

 

$02OSH:1$03

 

I would be a bit surprised if the carriage return is needed when ETX is used,

but if the above does not work, try it with the carriage return added.

 

$02OSH:1$03$0D

Share this post


Link to post
Share on other sites

Hi,

 

I've searched through the forum looking for answer to the problem I'm having right now with watch out and two panasonic projectors and couldn't find what I need.

 

I'm trying to open and close the shutter from the timeline in watch out.  I got both projectors to close once and then it wouldn't continue to work.  I took the admin password away for the panasonics….still didn't work. 

 

Using these two strings:

 

to close:

%1AVMT 31$0D

 

to open

%1AVMT 30$0D

 

Any thoughts on how I can the my panasonics and watch out to communicate?

 

Thanks!

Share this post


Link to post
Share on other sites

Hangam, 

 

What Panasonic projector is it, specifically?

To me it seems like it ought to work.

 

As I and JFK said in this recent thread on the forum:

 

Jonas: http://forum.dataton.com/topic/1421-internal-dowsing-tcp-commands/?p=5698

 

By searching the Forum for "Panasonic", "PJlink" and "Panasonic control", I found this:
 
 
 
 
 
is a "how to" for setting up and controlling the dowser of Panasonic projectors using the PJlink protocol.
 
Hope this helps,
/jonas

Share this post


Link to post
Share on other sites

Those are the correct strings. I usually put them in a task. 1 for open, 1 for closed. In that timeline, I put 2 copies of the command. 1 at .2 seconds, 1 at .7 seconds as a backup. They need some space or you will confuse the projector.  Also, search PJLink on the forum. JFK has a great tutorial with pics.

Share this post


Link to post
Share on other sites

Hi all,

 

Thanks for the suggestions, and links etc. We've tried everything and it still doesn't work through watchout. We can use a separate program and can make it work so through process of elimination it's watchout that's not working.

We're using 2 Panasonic pt-dz870u

 

We also know quite a few other people having this problem with panasonics and watchout.

 

Any other advice would be most welcome.

 

Thanks!

Share this post


Link to post
Share on other sites

I've used these commands succesfully on the 21, 6710, 770, 7700 and 110 so it should definitely also work on the 870 i suppose.

Perhaps a space before the carriage return?

Share this post


Link to post
Share on other sites

Hi,

 

Yes, that was a typo. We're still not having any luck getting the internal downer command to work consistently. Are there any other suggestions?

 

Thank you so much!

Share this post


Link to post
Share on other sites

Yes, I've assigned them as 192.168.0.7 and 192.168.0.8

 

Subnet is 255 etc

 

Still isn't working. We're having to use an external control to shutter the projectors this run, but I'd love to figure this out for the future.

Share this post


Link to post
Share on other sites

Hangam,

 

As you can see here, there are quite a few collegues here on the Forum,

who have successfully made this work.

So we know it works to control a Panasonic projector from within WATCHOUT.

It would be interesting hear back from you, what the issue where?

 

Just a final thought, all Display PC:s tweaked according to our guidelines?

Firewall/UAC/Windows Defender all OFF?

 

/jonas

Share this post


Link to post
Share on other sites

You have to set the admin password to blank, you have to turn pjlink on, and communicate on port 4352, not the port listed in the manual.

 

Shutter: %1AVMT 31$0D

Unshutter: %1AVMT 30$0D

Power on: %1POWR 1$0D

Power off: %1POWR 0$0D

 

Does this not work?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...