Jump to content
Dataton Forum

Display going full screen changes resolution


Recommended Posts

Hi guys,

I've got display computers with 4 output each. All 4 outputs are set to 1920x1200, when Watchout display software goes fullscreen output 3 and 4 change to 1920x1080 even though they are set to 1920x1200 in the production computer. On display computer 2 it also happens but on different outputs.

Display computers go to a Lightware MX2 matrix to Lightware fiber transmitter system to the Panasonic projectors.

Here is a video that shows it live.

Watchout 6.6.5
Nvidia Geforce RTX 2070 drivers 471.68 (we just updated them and it did not fix the issue)
Windows 10

Has anyone else experience this?
Any ideas how to fix this.

Thanks

Link to post
Share on other sites

Windows uses two different modes to drive a graphic card. So does WATCHOUT. Before WATCHOUT goes online, the display computer is in the GDI mode of the graphic card and to my understanding, the GDI mode is controlled by the Windows settings. When WATCHOUT switches to the online mode, it also switches to use the Direct3D mode of Windows to increase performance. In this mode you do not see any windows, menu bars,... and many computer games use this mode too when they run in full screen mode.

I guess that the Lightware fiber transmitter uses the wrong EDID information. Being a fiber transmitter, you probably have to teach the transmitter the correct EDID for the needed resolution and frame rate. If you just copy the complete EDID set from your projector, your graphic card is sort of free to negotiate a resolution while the graphic card will try to use the preferred resolution of the display.

The solution would be to teach your transmitter only the resolution it should use in online mode. This would force the graphic card to always use this resolution.

Since you're using NVidea you should also read the posting

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...