Jump to content
Dataton Forum
mouniroo

Control projector from production computer

Recommended Posts

Hi everybody,

Is there a way to send to the projector to SWITCH ON or SWITCH OFF from the RS232 of my PRODUCTION COMPUTER.

I know to string from a display computer but i would like to know if i can do the same with my PRODUCTION COMPUTER

My second question is : can we send strings to a videoprojector with network cable or we mus to use RS232 connection ?

Thanks

Share this post


Link to post
Share on other sites

No, only the display computer can send string through the RS232 port. But since the display computer is likely connected to the projector anywqay, why would you want to do it form the production computer?

 

Yes, you can also send strings using the network cable, either as TCP or UDP messages. Whether you rojector can receive and interpret such commands is of course another question.

 

Mike

 

Share this post


Link to post
Share on other sites

Hi Mike,

Thanks for your reply.

The reason why i wanted to do it with the production computer is because i have no more place on my display motherboard to setup my RS232 card :) , i will buy a USB to RS232 and connect it to the display.

 

I need to check if my projector (christie DHD 800) can communicate by TCP or UPD.

 

Thanks for your reply Mike

Share this post


Link to post
Share on other sites

Hi Mike

thanks for your reply.

Just to be sure but i will test it tomorrow....

This is means that i can use string output my projector with network port TCP and ip port 1000 ? and if i tape the command C00 my projector will switch SWITCH ON ?

Thanks for your help Mike

Share this post


Link to post
Share on other sites

I suggest you try the commands fmor a telnet client first, just to make sure you have the syntax OK, before you try it from WATCHOUT. Their manual describes using a telnet client, so I suggest you start there. Once you get the syntax OK, you should be able to send the same strings from WATCHOUT.

 

Mike

Share this post


Link to post
Share on other sites

Hi Mike,

I test with usb to rs232 and it works fine. command is : C00$0D

I test the command from telnet and it works fine but in watchout, i can not string by tcp or upd, i use the same command (i add also $0D)

But it is not a big deal, because my rs232 is working.

Thanks for your help mike

Share this post


Link to post
Share on other sites

If it works from telnet, I see no reason it shouldn't work also from WATCHOUT assuming you send the same commands to the same TCP port on the same address as you do with telnet. But good that you found a way to make it work with RS232 anyway. Did you set up an access code? The docs mentioned such a four digit code. If so, you must use it as a password when connecting through TCP port, as far as I could tell from a cursory look at their protocol. Dunno what happens if you don't set a passcode, though.

 

Mike

Share this post


Link to post
Share on other sites

Hi Mike,

i didn t set a password.

BUT  i have a doubt with my PORT..it seems to be 10000 but not working.

I don t know what port use my DHD800, i call christie they told me 3001. i try but not working.

As i am finalizing my setup, i use the rs232.

I am pretty sure that the PORT is wrong that s why it is not working by TCP IP.

Thanks for your help mike.

Long life to dataton

Regards

Share this post


Link to post
Share on other sites

Hi Everyone, 

 

Has there been any more investigation in controlling the Christie DHD800?

 

I am working with WO 5 and trying to send TCP commands but getting no response from the projectors. 

 

 

Sending Command: C0D$0D & C0E$0D

on Port 3002

 

I also tried sending:

 

Commands:

SHUT1$0D & SHUT0$0D

 

SHU0$0D & SHU1$0D

 

Port 3001 and 10000

 

When I use telnet I have no problems sending the command C0D and C0E.

 

Any thoughts on why the projectors are not seeing the TCP command when sending through WO?

 

 

The network manual mentioned that the connection will be closed after 30 seconds. Do I need to send a command to open the port first and then send the shutter command?

 

Thanks!

Joe

Share this post


Link to post
Share on other sites

Depends on time position of the cues and the state of the auxiliary timeline at the time you play it.

If the timeline is in Stop mode and the first command is at time 0, it will be skipped.

If you send a pause to the aux timeline first and wait a few tenths of a second, it will execute.

alternately, place you first command at about 0.300 seconds and the state of the aux timeline will not matter.

 

As for holding the connection open between commands, the timeout is much longer than 1 second,

so that should be fine

Share this post


Link to post
Share on other sites

Regarding the PW:

This function is shut off for the projector and there is no password set. When I use telnet to access the projector the projector requests a password and i enter nothing, just hitting enter. Then the connection is made and I can send commands. 

 

Regarding the aux timeline: 

I places the first command at .300 from the start of the timeline. direct the command and no response. 

 

The WO manual mentions that it will open the connection and send the data to the device (projector).

The Christie CHC800 network manual mentioned that the connection will be closed after 30 seconds, so I assume that the connection closing is not the issue. 

 

Any more ideas?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...