Jump to content

Geometry tab distorts Media when 'Suppress Rendering' is enabled?


Thomas Leong
 Share

Recommended Posts

Watchout v6.02.

I have a mask (of a car's outline; black car on white background) with 'Suppress Rendering' enabled and Image Blend Mode = Normal; on Layer 2 in the Timeline.

In the layer below (Layer 1), I have a red solid as background with a setting for 'Masked by Layer Above: Luma Mask' or 'Luma Mask Inverted' as the case may be.

Both are 1920x1080 resolutions and positioned to fill a Stage 2D Display of 1920x1080.

 

When 'Suppress Rendering' is enabled, the Geometry tab shows a distorted mask (the black car) regardless of Geometry being None, Perspective, Horizontal, Vertical, or Full. The distortion can be described as taller, less wide, and Y position moved down by about -162 pixels (owing to the distortion; i.e. instead of the black car's wheels at the lower bottom of screen, the black car has been displaced by about -162 pixels vertically such that the wheels are no longer visible in the Geometry window).

 

The Mask tab, however, shows the mask in its proper proportion with no distortion.

 

Toggling between Geometry and Mask tabs, it seems that the aspect ratio of the Display (and the media contents in the Display) changes under Geometry.

 

Is this a bug? Have not tried earlier versions or v5.5.2 yet.

 

Thomas Leong

Link to comment
Share on other sites

Not possible to see if there is any distortion of the mask with v5.5.2 since the Geometry tab in this version does not super the grid over the media.

 

A simple Circle mask with 'Suppress Rendering' enabled illustrates the distortion clearly in the Geometry tab. Happens only in the Production PC. Does not distort in the Display PC. But then, if the mask is distorted, how would one go about accurately correcting geometric points with the Production PC?

 

My workaround for the moment is to not use the 'Suppress Rendering' feature and have instead 2 masks of the same object, one the negative of the other.

 

Thomas Leong

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...