Jump to content

No output through StarTech DP2DVIS adapters


Recommended Posts

Hi guys


I realise this isn't really a Watchout problem but I wondered if any of you have encountered this before?


I have a new Watchout system with a couple of PCs with AMD FirePro W7100s, having read the info on this forum and elsewhere, I thought it was best to purchase the StarTech DP2DVIS adapters (http://www.amazon.com/StarTech-com-DP2DVIS-DisplayPort-Active-Adapter/dp/B004SUO1GMas) listed in the AMD Recommended Adapters list (http://support.amd.com/en-us/recommended/eyefinity-adapters).


Being based in Dubai, all of the above was very difficult to source but now I have everything, only to find that when I connect the output from the W7100 into a DVI monitor via the StarTech adapter, I get no signal and the monitor goes to sleep.


The strange thing is that if I reboot the PC, the monitor comes back on and displays the BIOS and Windows loading screen, presumably because its low-res and its before any graphics driver has kicked in and told it to do something else.

This has lead me to believe that it could be a setting somewhere that I am missing...unless anyone here can tell me different?!


Also, I have tried all of the above using an unbranded cheap and nasty DP to DVI adapter purchased from a local supplier and much to my surprise, that one worked fine!


Any help would be greatly appreciated!




System specs:

Watchout v6

Windows 7 Professional

Intel i7-5930K 3.5Ghz

16GB Corsair Vengeance DDR4 PC-2666Mhz

AMD FirePro W7100

128GB Samsung Pro 850 SSD

512GB Samsung Pro 850 SSD

Link to comment
Share on other sites

Hi Walter


Oops, yes display details would have been useful! I'm trying it with a Samsung S24B300 monitor. 


Being an LED screen company, I have also tried plugging it into a Calibre LEDView 530 which is usually a very forgiving LED scaler but that doesn't detect an input either.


I tried using the EDID emulation in the AMD Control Panel which didn't seem to make a difference, I don't have any hardware EDID managers as of yet.


I don't know if the cheap adapters that worked are active or passive, could that have anything to do with it?




Link to comment
Share on other sites

I've experienced a black output with the W7100 before with similar hardware specs to yours...well, at least a couple of times with different units of W7100.

The W7100 comes with 2 DP-DVI Adapters (probably white heads). These are not ACTIVE, but will work. Try with these. Maybe your Startec is defective. How many do you have? Swapped them around?


Also, try another port of the W7100 with your one monitor. If system is already booted up, and nothing shows, try the other ports one by one.

If still nothing shows up, then leave it plugged into one of the 4 ports, and re-boot Windows. Nothing? Do the same with the other ports one by one.


If eventually, the desktop shows up, go into AMD Catalyst Pro, and disable EDID Emulation if already enabled. Scroll down and delete also for each connection (whether or not connected) any EDID profile saved. Also, look for a software switch which says something like 'Delete all emulations' or equivalent. Your objective is to wipe off any EDID saved previously, i.e. let the W7100 start from scratch/fresh out of the box. Shut down. Plug the adapter in the first port (from top down), and boot up. Hopefully this solves it.


If it does not, next best thing is to boot into the Windows install CD or Windows USB. Nothing shows up, try another boot up. Hopefully one of the cold boots show up the installation procedure. Wipe off the present partition and re-install Windows from scratch.


Thomas Leong

Link to comment
Share on other sites

Hi Thomas


Thanks for your advice!


You are right, the W7100 came with a couple of adapters and they work. I have 10x StarTech adapters and not one of them works which leads me to believe its got to be a software/config problem and not a defective adapter (how likely is it that all 10 are faulty?!)


I will try your suggestions with regards to port swapping and EDID emulations before I go to drastic measures of re-installing Windows!


Thanks again...



Link to comment
Share on other sites



Thinking more about it, I don't think the W7100 has a built-in EPROM for the EDID. Instead it is highly likely in the software - Catalyst Pro.


So perhaps a quicker way may to be to uninstall the drivers and Catalyst Pro. Use Windows' built-in VGA driver with one of the non-Active DP-DVI adapters to do all these. Use ccleaner to wipe the registry. Reboot and hopefully system has been cleaned of AMD stuff and you are back to square one. Check in Device Manager that it is using the Windows VGASave driver for the graphics card. Now install the Catalyst Pro...and hopefully, all will be ok with using the Startec adapters now (you are right: what are the chances of all 10 units being defective?).



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...