Jump to content

ip issues - 5.5


dotninedesigns
 Share

Recommended Posts

I have a bunch of custom built i7 Machines on a show with dual ethernet ports. I have disabled one of the ports and have assigned static ip's to all the machines (starting at 192.168.1.101 - 105 ) for some reason no matter what I do, when I launch Watchout display it shows me ip addresses in the 169 range. Any ideas / suggestions?? Thanks!

 

Geoffrey!

Link to comment
Share on other sites

It looks like WATCHOUT starts a bit before Windows networking is all up and running.

Try this:

  • A command line option is added to the display software, allowing a delay to be introduced when the software is started. This may occasionally help in avoiding start-up problems, by delaying the start of the display software until things have settled down. To use this feature, append -Delay 3 to the shortcut used to start the display software ("WATCHPOINT.EXE"), where 3 is the desired delay in seconds.

from the "5.5 Release Notes" found here:

http://www.dataton.com/downloads/watchout/support/Release-Notes-55.html

 

/jonas

Link to comment
Share on other sites

This is the first time I have bought and used a display with 6 display outputs (Win7). It is so fast that it boots and loads Watchpoint in a few seconds. Which is great!

 

However I too get an incorrect IP address of 169.254.231.114 displaying in Watchpoint. Which can mean that there are other adapters connected/configured as Jim states, but this is not the case here.

 

My production laptop (Win8) is connected directly with ethernet cable. I can ping to the correct IP of 192.168.0.102 successfully. Therefore I came to same conclusion as noted by Jonas that it is starting before Windows has completed. Also because once the display software is up and running showing the wrong IP, I then relaunch it and it finds the correct IP address of 192.168.0.102

 

If I use a switch between the two computers it finds the correct IP address. However I would prefer not to use a switch for this stand-alone installation if possible.

 

I therefore tried Jonas' suggestion

 

It looks like WATCHOUT starts a bit before Windows networking is all up and running.

Try this:

  • A command line option is added to the display software, allowing a delay to be introduced when the software is started. This may occasionally help in avoiding start-up problems, by delaying the start of the display software until things have settled down. To use this feature, append -Delay 3 to the shortcut used to start the display software ("WATCHPOINT.EXE"), where 3 is the desired delay in seconds.

from the "5.5 Release Notes" found here:

http://www.dataton.com/downloads/watchout/support/Release-Notes-55.html

 

, but appending -Delay 3 (or any number) to the shortcut Target makes no difference to the startup time.

"D:/WATCHOUT/WATCHPOINT.EXE" "-delay 10"

NB: without the " " , Windows gives an error indicating that the entry is incorrect, so perhaps the Users Guide screenshot could be updated?

 

I have added it to the shortcut in the main Start menu as well as the one found in ProgramData/Microsoft/Windows/Start Menu/Programs/Watchout5

 

This is possibly also related to the issue I have in adding commands to the autostart.txt file (either direct or using the Edit Startup Script from the display file menu.

 

I want to run this display as a cluster (which I have done many times with previous versions of Watchout and XP) so that it starts the show automatically after booting up and executing the display software. The show is in a folder called Shows inside the folder that contains the Watchpoint.exe

 

The script I use is below but when I boot the pc the only change is that the display has the line "The show will begin shortly" but it doesn't.

 

authenticate 1
setLogoString "The show will begin shortly"
delay 8000
load "Shows/Performance Today"
wait
run

 

Perhaps I am missing something, I also tried ommitting the "Shows/" from the load command.

Link to comment
Share on other sites

AGR, on 14 Jul 2013 - 12:16, said:

This is the first time I have bought and used a display with 6 display outputs (Win7). It is so fast that it boots and loads Watchpoint in a few seconds. Which is great!

 

However I too get an incorrect IP address of 169.254.231.114 displaying in Watchpoint. Which can mean that there are other adapters connected/configured as Jim states, but this is not the case here.

 

My production laptop (Win8) is connected directly with ethernet cable. I can ping to the correct IP of 192.168.0.102 successfully. Therefore I came to same conclusion as noted by Jonas that it is starting before Windows has completed. Also because once the display software is up and running showing the wrong IP, I then relaunch it and it finds the correct IP address of 192.168.0.102

 

If I use a switch between the two computers it finds the correct IP address. However I would prefer not to use a switch for this stand-alone installation if possible.

Well that is the issue, when the computers boot up they do not yet see the connection to the other computer.

when the switch is present, the connection is ready.

When direct connected, it is not ready yet.

Put a USD$20 100base-T switch in if you must, but your direct connection is the root of that issue.

 

AGR, on 14 Jul 2013 - 12:16, said:

 

I therefore tried Jonas' suggestion

 

 

, but appending -Delay 3 (or any number) to the shortcut Target makes no difference to the startup time.

"D:/WATCHOUT/WATCHPOINT.EXE" "-delay 10"

NB: without the " " , Windows gives an error indicating that the entry is incorrect, so perhaps the Users Guide screenshot could be updated?

May just be a copy and paste issue, but, as written above the behaviour you describe is expected.

the target string is missing the space delimiter required before the command line switch

and there should be no quotes around the command line switch.

Should be

"D:/WATCHOUT/WATCHPOINT.EXE" -delay 10

 

AGR, on 14 Jul 2013 - 12:16, said:

I have added it to the shortcut in the main Start menu as well as the one found in ProgramData/Microsoft/Windows/Start Menu/Programs/Watchout5

 

This is possibly also related to the issue I have in adding commands to the autostart.txt file (either direct or using the Edit Startup Script from the display file menu.

??? what kind of problems, can you not edit the text file directly?

 

AGR, on 14 Jul 2013 - 12:16, said:

I want to run this display as a cluster (which I have done many times with previous versions of Watchout and XP) so that it starts the show automatically after booting up and executing the display software. The show is in a folder called Shows inside the folder that contains the Watchpoint.exe

Yes it is and the show's location is handled by watchpoint directly.

When calling a show from a script, the location of the show is not an option,

it is already predetermined by watchpoint.

So enter only the show name, exact case and spacing.

 

AGR, on 14 Jul 2013 - 12:16, said:

The script I use is below but when I boot the pc the only change is that the display has the line "The show will begin shortly" but it doesn't.

 

authenticate 1

setLogoString "The show will begin shortly"

delay 8000

load "Shows/Performance Today"

wait

run

 

Perhaps I am missing something, I also tried ommitting the "Shows/" from the load command.

And you should omit any path name from the load command.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...