Jump to content

Companion Streamdeck Connection with Watchout


DanielB
 Share

Recommended Posts

Hey guys, 

I am a bit lost and can't find the issue here. I got a streamdeck connected to my Production Laptop. I wanted to control some of my Aux-timelines with the streamdeck. 
But I can't get companion connect with watchout. Here is what I did:

- Opened a new Project and checked TCP/IP & UDP Control under settings
- launched Companion as localhost with Port 3040 (and tested it with 8000)
- created a new module from the "Watchout" Database
- Typed in the IP Adress of the Production Laptop (But also tested it without IP)

- I also started the Configuration Wizard to see if there is anything relevant. But made no changes. 

I always get a connection Error when trying to connect and don't really know what's wrong. 
I did the same thing many times before without such problems, so I can't really see what's wrong here. Hope to get your help for this. 

Best Daniel

Link to comment
Share on other sites

Hi,

Just a guess but, assuming that nothing is being blocked by a firewall, I think it might be some confusion about the ports that's causing the problem. Companion needs to talk to Watchout Production on port 3040, but the Companion server can run on any port - I usually use it on localhost using the default port (23456). If Companion is listening on the same port as Watchout, messages might be getting lost.

And I always specify the IP of Watchout Production in Companion - using 127.0.0.1 if you're running on the same laptop.

Link to comment
Share on other sites

Good Morning and thank you for your response Mat. 
Using the localhost IP 127.0.0.1 helped getting a stable connection. 
I logged into the GUI on Port 8000 and got back to the default port for Companion. 

My Aux-Timelines can be controlled now. Thanks a lot

Daniel

Link to comment
Share on other sites

  • 2 weeks later...

hi

how do you succeed in controlling aux timelines with companion ?

i can't make a specific time line to run, only locate works, but "play" make run the main timeline, not the aux one i want to play.

 

Thx

Link to comment
Share on other sites

To play an auxiliary timeline, you must add the timeline name to the run command. Note, the timeline name must be an exact match, case sensitive. i.e.

run “Timeline 1”

Link to comment
Share on other sites

Hey,
Like jfk said you have to specify the timeline that needs to be controlled. The exact same writing is important. 
 

When you add the Watchout command "run" there is an empty field called "timeline" there you will have to fill in the timeline you want to control. And that's it. 

Link to comment
Share on other sites

I found one way to do this, but it's not foolproof. The first step is to add an Output to the Watchout project with the IP & Port of the Companion software, so that you can send messages from Watchout to control the Streamdeck. I added a String output to send UDP commands to 127.0.0.1 on port 51235. Under the 'settings' tab in Companion, there is a section titles 'TCP/UDP REMOTE CONTROL' where you can find the port to use for listening.

Drag the Output to your Task timeline and then use something like the following to change the colour of a particular button:

STYLE BANK 1 10 BGCOLOR 66FF66

Format is : COMMAND BANK {Page No} {Button ID} BGCOLOR {HEX Colour without the preceding #}

Add an Output cue at the beginning and end of each Task to trigger a colour change on the appropriate button on the Streamdeck. A major limitation of this method is that, if you stop the Task manually in the Watchout UI, the Output cues don't get sent and the Streamdeck ends up out of sync with the actual state of things. I guess you could use a third-party app to monitor the status of the timelines and update the Streamdeck, but that seemed a bit over the top for my needs.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...