Jump to content

Audio Popping and DVS Issues


QuinLoft
 Share

Recommended Posts

Hi all,

Trying to troubleshoot some weird audio popping. One thing I've noticed, is for some reason whenever I have an audio file coming up, Watchout seems to pre-load it 3 seconds beforehand, not 0.3. I know this because the speaker pops like something is turning on 3 seconds before the clip is due to start. I know the first thing will people will suggest is to put a fade in on the clip, which I've done. In fact, I have the first second of the clip at 0%, so it's not that. This happens on any clip. I'm running Dante ASIO at 48k, and all files are WAV 16bit PCM. Crossfading an audio file with another will give me the popping too. (On the same channels.) If I put a put a pre-roll above 3 seconds, it seems to do it at the beginning of the assigned pre-roll. Anyone know if this is something that's WO related or Dante related? It's pretty annoying.

Also does anyone know how default DVS to 48k instead of WO assigning it as Auto? Auto doesn't work. We have a network switch that occasionally has to go offline, and it kills the DVS service. Trying to walk someone through how to reassign this on phone tech support is annoying.

Link to comment
Share on other sites

7 hours ago, Benoit said:

Hi Quinoft,

With DVS it's mandatory to select sample rate in the Watchout player audio out menu.

Did you try to increase the buffer size in the DVS interface?

Good luck.

Benoit

I don't mind selecting the sample rate, I just wish Watchout actually remembered which sample rate was selected. That it goes back to Auto every time is frustrating.

I'll be honest, I'm an idiot when it comes to audio things. Would the buffer size help minimize pops? Is there recommended ASIO settings for WO?

Link to comment
Share on other sites

Strange, on what hardware do you have this issue? Watchout write somewhere the settings and is not supposed to lost it…

Yes, increasing the buffer size might have a positive effect to reduce audio pops. Basically there is a buffer of data between the application and the real audio output.

The smaller it is, the less delay there is between the app and the real audio output. Which is something good on DAW, when you’re a musician and the delay of the system might conflict with real instruments or other sound processors.

For audio playback, delay doesn’t matter, because a “big” buffer is something like 4096 samples, but there are typically 48 000 samples per seconds. I’ll let you do the math, but you may delay the audio by 1 or 2 video frames… Not noticable.

On another side, a small buffer requires the app to fill the buffer more often and when you have other highly CPU intensive things to do, your system might not be able to do it as often as required. It’s way easier for a computer to do it less often and fill a bigger buffer.

Short answer: For Watchout, set the audio buffer to the maximum possible value, you will not have visible downside.

Hope this helps.

Benoit

Link to comment
Share on other sites

On 12/21/2022 at 1:15 PM, Benoit said:

Strange, on what hardware do you have this issue? Watchout write somewhere the settings and is not supposed to lost it…

Yes, increasing the buffer size might have a positive effect to reduce audio pops. Basically there is a buffer of data between the application and the real audio output.

The smaller it is, the less delay there is between the app and the real audio output. Which is something good on DAW, when you’re a musician and the delay of the system might conflict with real instruments or other sound processors.

For audio playback, delay doesn’t matter, because a “big” buffer is something like 4096 samples, but there are typically 48 000 samples per seconds. I’ll let you do the math, but you may delay the audio by 1 or 2 video frames… Not noticable.

On another side, a small buffer requires the app to fill the buffer more often and when you have other highly CPU intensive things to do, your system might not be able to do it as often as required. It’s way easier for a computer to do it less often and fill a bigger buffer.

Short answer: For Watchout, set the audio buffer to the maximum possible value, you will not have visible downside.

Hope this helps.

Benoit

Sorry for the delayed response. I've been out a bit for the holidays. The hardware is a brand new Showsage PC that's integrating with a Q-SYS system handling Dante. I don't remember what speakers are being used, but they're definitely a Prosumer product. I believe they're JBLs.

Thanks for the suggestions, I won't be back for a few days, but I'll see if the buffer manages to fixes anything.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...