Jump to content

PJLink from Watchout Crashing Projectors.....?


Recommended Posts

Hi All,


So I've got a strange problem I haven't encountered before. I've got 3 panasonic DZ870's that I'm trying to send PJLink shutter and power controls to. I've successfully tested the connection and commands on my personal laptop with Netcat, but when I run the same command from Watchout, it runs the command... and then does not respond to any other command. when I go back into Netcat, it fails to connect. I've left it sitting for 15 minutes to see if the connection would reset, but nothing changes. I'm locked out of any commands until I disable PJLink in the projector and re-enable it.


for example, I'm setting an output with a TCP connection to the projector at, port 4352. I drop it in the timeline and give it the message "%1AVMT 31$0D". Later in the timeline (30 seconds or so) I drop in the connection again and give it the message "%1AVMT 31$0D". I run the timeline. the shutter closes when it hits the first command, but will not reopen, and will not respond to any AVMT, POWR, or query commands, nor a connection request from Netcat, until resetting the PJLink option in the projector. I thought it might be a projector issue, but it works just fine with Netcat (until I run a command from Watchout).


I've dumped my show, i've tried other commands, running it in and out of tasks, I've restarted computers. it does the same thing if the first command is something else (power off, power on, open shutter). Sending the projector to standby does not fix it, but pulling power does. I couldn't find a similar issue in the forums; Anyone encounter a problem like this before, or have a possible solution?




Link to comment
Share on other sites

It seems your two methods for sending commands to the projector behave differently. One difference I can think of is that the TCP connection from WATCHOUT remains open for some time after using it (dont' recall the exact time), while netcat likely drops the connection right away. You may be able to get more details on what's different by monitoring the communication using Wireshark.



Link to comment
Share on other sites

Thank you Mike! I looked at what I got over Wireshark, and I noticed that the projector was sending its connection acknowledgment (PJLINK  0) after I had already sent the data stream. I threw together an Isadora patch that would breakup the connection, message, and termination. I found that when I stepped through the 3 under .05 seconds sequentially, i got the same problem as Watchout; when I raised it to 1 second sequentially, it worked just fine (Wireshark gave me 0.119 secs between connection start and the connection acknowledgement). 


So the question now is how can I break up an output message or slow down an output message in Watchout? Or do I need to leave an IP sending and receiving max/izzi patch running in the background / some other outside of Watchout solution?

Link to comment
Share on other sites

I have not run into the problem you are describing exactly, but I have used PJLink on many occasions and it's always been fine. I put all the tasks in an AUX timeline each on a different layer at .01seconds, and then repeat those commands about .5 seconds later. I then trigger the aux timeline from the main timeline. I close and open all 3 no problem, and power on and power off always work too. Suggestion: put a pause in the AUX timeline for power off so you have to click the button twice, otherwise you might have to wait awhile if you click the power off timeline accidentally.

Link to comment
Share on other sites

  • 2 weeks later...


We have a strange issue on a show at the moment. Using the PJlink commands to open and close the shutter of 2 panasonic Pt D21K projectors.Through out the show the aux timelines are triggered to open a nd close the shutters a number of times however in 1 specific instance,

we send an open shutter command to 2 projectors at a certain point in the show. We get 2 error messages that say the message couldn't be sent but the shutters do open?


Any thoughts.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...