Jump to content
Dataton Forum
rrader

Problems with gotoControlCue

Recommended Posts

We recently upgraded from 6.2 to 6.5.  Now when the external command "gotoControlCue idle1" is run from a remote box it works great.  When any other gotoControlCue to a differnt time slice area the screen just flickers on the current time slice and doesn't move.  If you put the system in Offline then it shows immediately where it should be and then requires putting the system back online which can take a bit of time.  Our system has a production server and 6 display servers with 6 displays on each of them so a total of 36 displays.

Not sure if there is a better way to run the commands.  The system is used to display an award over a slot machine so on every call the award characters are reset to 0,0 just in case so that they do not show over a machine.

authenticate 1
setInput "TimeHop1x" 0
setInput "TimeHop1y" 0
setInput "TimeHop2x" 0
setInput "TimeHop2y" 0
setInput "TimeHop3x" 0
setInput "TimeHop3y" 0
setInput "TimeHop4x" 0
setInput "TimeHop4y" 0
setInput "TimeHop5x" 0
setInput "TimeHop5y" 0
gotoControlCue idle3
run

 

The production server is correct and showing on the preview the right timeline however the display servers are flickering from their last timeline and no updating.  If I go to offline and then online they will synchronize correctly.

Share this post


Link to post
Share on other sites

Are you controlling the production computer or the display computer? You claim that the production computer handles everything correctly but the script implicates that you control the cluster (no production computer online). To narrow down I would first use a simple telnet tool like Putty to send the commands since then you'll see all the feedback from the system including any error messages which may lead you further.

Share this post


Link to post
Share on other sites

I had some similar strange behaviour while upgrading from 6.2/3 (don't remember exactly) to 6.4.1/6.5.

Try writing again ALL your parameters within the control cue, and test it to see if this causing the problem.

Share this post


Link to post
Share on other sites

Remember to quote the target cue name if it contains spaces or other odd characters, Easies is to always quote strings.

Mike

Share this post


Link to post
Share on other sites
On 1/28/2020 at 4:48 PM, Michael said:

I had some similar strange behaviour while upgrading from 6.2/3 (don't remember exactly) to 6.4.1/6.5.

Try writing again ALL your parameters within the control cue, and test it to see if this causing the problem.

sounds interesting as I have encountered similar issue recently while sending "gotoControlCue video0" to WP20 version6.5, but somehow it wouldn't happen again after few reboot. I thought it was a coincidence at that time and didn't look into it too much. Good to know.

Share this post


Link to post
Share on other sites

I remember a strange behaviour after an update to 6.2.?, we used telnet commands to load shows and goto cues, so there was a list of commands that where sent. After the update it was necessary to wait for the ready message from the display cluster to have the gotoControlCue command worked like before - if you used to have a fire and forget onedirectional approach to use remote commands, it is very funny to implement something bidirectional in some hours to have the show going on next day. These are these little easter eggs you always have to expect after each update...

Share this post


Link to post
Share on other sites

I use putty and simple commands being passed to the device an example is posted below.   Here is the batch I use:

d:\Data\sfcBonusWO\plink.exe -raw 10.10.36.100 -P 3040 < "D:\Data\sfcBonusWO\WOBonusReset.txt" > "D:\Data\sfcBonusWO\WOBonusResetStatus.txt"

 

Here is the contents of the WOBonusReset.txt

authenticate 1
setInput "TimeHop1x" 0
setInput "TimeHop1y" 0
setInput "TimeHop2x" 0
setInput "TimeHop2y" 0
setInput "TimeHop3x" 0
setInput "TimeHop3y" 0
setInput "TimeHop4x" 0
setInput "TimeHop4y" 0
setInput "TimeHop5x" 0
setInput "TimeHop5y" 0
gotoControlCue idle1
run
 

Share this post


Link to post
Share on other sites

If you set all inputs with a ramp of 0, why don't you use the setImputs command instead?

setInputs  (page 183 of the current manual)
This command is functionally equivalent to the setInput command above, but allows you to set multiple
inputs with a single command. This is useful in the following cases:
• When it is important that several inputs are set simultaneously, because their values are used in an
interdependent way. If you use two separate setInput commands, it is possible that the commands
will not be executed on the same frame.
• When setting a large number of inputs, as it is more efficient to handle this with a single command
than a number of separate commands, allowing you to set a larger number of values within a single
frame.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...