Jump to content

Watchout Display machine crash, production no any message


Recommended Posts


I have a problem at watchout 6.2.2. Just when watchout running several hours or one days, the display machine jump to watchout logo, but on production machine looks ok, no any message, 

but offline and online can't slove it. need close watchpoint and restart watchpoint. 

does anybody meet same problem?


Link to comment
Share on other sites

We have experienced similar problems. Some things we have encountered, I have only seen since switching to v6.2.2. We are currently running tests to try to determine what behavior is causing some new, odd behavior. The most perplexing thing I recently experienced is I had a display machine, in which had been sitting completely idle in a static image state (JPEG and PNG images) for 15 minutes, suddenly gave away focus to the desktop. No report to production at all, because it seemed as if WP was completely unaware that focus had been taken away. AFAICT - from reviewing things like task manager, WP still thought it was in full screen, full system focus mode. I essentially had to click "Switch To" from task manager to restore full screen WP.

We are now back at our shop re-evaluating the show file and are experiencing behavior similar to what you are describing... which I would not necessarily say is limited to v6.2.2, but we certainly are finding easier ways to reproduce. I am hoping to package a reproducible case to send to support today.

Link to comment
Share on other sites

  • 3 weeks later...

I've had this issue a couple of times now.

I was projecting an image across two displays, then suddenly the watchout-logo and the windows taskbar appear. Offline/online does not help, and I have to restart watchpoint. And when I do go online again after restart, the watchout-logo flashes a few times, then everything is back to normal.

Today I was starting up the watchout project, went online and the same thing happened.

Any ideas?


Running 6.2.2, Win7 tweaked.

Link to comment
Share on other sites

  • Dataton Partner

What do the log files say? Check the log files in the logs folder inside your WATCHOUT folder on the display computer and on your production computer. Also check the Windows events logs.

Culprits could be hardware issues, encoding issues or tweaking issues. I had the latter in a client's installation where some players would show such behavior exactly once a week. Here it was the Windows scheduler for QT updates which tried to search for updates once a week. (tweaking issue, though the client insisted that he fully tweaked his computers)

It could as well be a problem with your RAM. Have seen such things before although the RAM was selected from the QVL of the mainboard manufacturer. Run a test with a good tool, e.g. MemTest, not only using the internal Windows memory test app.

Link to comment
Share on other sites

Thanks for your reply.

So, the watchout-logs for yesterday (when I had the error) say nothing other than "Starting watchpoint" which I guess is logged after I restarted the computer. Should I assume then that watchpoint itself did not crash?

Looking at the windows event viewer, there were loads of entries - but there were entries also on every day that seemed pretty routine. Like "Microsoft Antimalware has discovered an error by trying to update signatures" (translated from the - sadly - norwegian error log).

Along with that one, were entries from something called "iumsvc 255". Each error entry from iumsvc notes that it cant find the event description for this event ID, but the following information was included:

Exception : ('Device Profile Push Failure', 
ConnectionError(MaxRetryError(""HTTPSConnectionPool(host='servicegateway.intel.com', port=443): 
Max retries exceeded with url: /DeviceProfile/Service.svc/Rest/DeviceProfileManager?deviceId=73d6cf7b-56b6-41c4-9ca3-038c0f4ac9b7&DomainId=4E00205A-2AB1-4423-8F77-CC25B82CDE1D 
(Caused by <class 'socket.gaierror'>: [Errno 11004] getaddrinfo failed)"",),))


Looking at entries here on past days which didnt have any troubles, I saw that this one stuck out:

Advarsel    18/10/2018 16:14:34    e1rexpress    27    Ingen    "Intel(R) I210 Gigabit Network Connection
 Network link is disconnected.

Feil    18/10/2018 16:14:32    Microsoft-Windows-Kernel-EventTracing    3    Økt    Økten Microsoft Security Client OOBE stoppet på grunn av følgende feil: 0xC000000D

Feil    18/10/2018 16:14:30    Application Popup    56    Ingen    Driveren PCI returnerte en ugyldig ID for en underordnet enhet (0000000101000A3500).

Advarsel    18/10/2018 16:13:42    Microsoft-Windows-User Profiles Service    1530    Ingen    "Windows oppdaget at registerfilen fremdeles er i bruk av andre programmer eller tjenester. Filen lastes ut nå. Det kan være at programmene eller tjenestene som bruker registerfilen, ikke vil fungere på riktig måte etterpå.  

 1 user registry handles leaked from \Registry\User\S-1-5-21-3446684556-2762053742-1911376174-1000:
Process 480 (\Device\HarddiskVolume3\Program Files\NVIDIA Corporation\NvContainer\nvcontainer.exe) has opened key \REGISTRY\USER\S-1-5-21-3446684556-2762053742-1911376174-1000\Software\NVIDIA Corporation\Global\ShadowPlay


Not sure what this ones about, but looking at the time I am pretty sure they occurred just as I was restarting the computer.

I have attached the log from the windows event viewer from yesterday. It is sadly in norwegian, but the source IDs should be the same -  as well as the error codes.

Addendum: Browsed a bit further back in the watchout-logs and saw these:

"Watchpoint exited abnormally (code 3), restarting"
"Watchpoint exited abnormally (code 1073807364), restarting"

But since they were not on the date I had the trouble, I disregarded them. But maybe interesting?



Link to comment
Share on other sites


ASRock X99 WS, Socket-2011-3  E-ATX, X99, 8xDDR4, 6xPCI-E, UltraM.2 x4
Intel Xeon E5-1650v4, Socket-2011-3 6-Core, 3.6GHz, 15MB, 140W, 14nm
Crucial DDR4 2133MHz 32GB RegDIMM 32GB Kit (8GBx4) DDR4 2133 MT/s (PC4-
EVGA GeForce GTX 1080 Founders Editio HDMI 2.0, 3x DisplayPort, VR-Ready, Twin
Samsung SSD 950 PRO 512GB M.2 PCIe M.2, PCIe 3.0 x4 NVMe1.1, Samsung UBX, 2

Samsung SSD 850 EVO 250GB 540/520 mb/s R/W

Link to comment
Share on other sites

  • Dataton Partner



Are there any services running in the background? Port 443 is not used by WATCHOUT, it's the https port. It tries to open a connection to 


This looks to me as a problem with insufficient tweaking. Things like malware detection and Microsoft Security Client should also not be active.

I would suggest to go through the tweaking list one-by-one and disable everything which is not needed for very basic computing. Also delete any bloatware from the PC manufacturer if there is any installed.



Link to comment
Share on other sites

Thanks again for your follow-up.

I did go through the tweaking list again, and the only aberration I could find was that it still was indexing the start menu. I tried to disable that, but couldnt figure it out.

Where did you find the line of servicegateway.intel.com?

I think the regular findings of Microsoft Antimalware is weird. Windows Defender, Firewall and Update are all disabled. Is Microsoft Antimalware a program independent of those 3 mentioned?


Link to comment
Share on other sites

  • Dataton Partner
On 10/19/2018 at 3:58 PM, asmundboe said:

Exception : ('Device Profile Push Failure', ConnectionError(MaxRetryError(""HTTPSConnectionPool(host='servicegateway.intel.com', port=443): Max retries exceeded with url: /DeviceProfile/Service.svc/Rest/DeviceProfileManager?deviceId=73d6cf7b-56b6-41c4-9ca3-038c0f4ac9b7&DomainId=4E00205A-2AB1-4423-8F77-CC25B82CDE1D (Caused by <class 'socket.gaierror'>: [Errno 11004] getaddrinfo failed)"",),))

The Windows Antimalware is part of Defender. Should be the executable MsMpEng.exe.

The servicegateway.intel.com is part of what you posted (see above).

So it seems that your computer tries to connect to the outside and does things in the background which you do not really want.

Link to comment
Share on other sites

Yes, so it would seem. Iumsvc is apparently the intel update manager or somesuch, and together with the antimalware I guess they are still working in the background.

I will check if its possible to uninstall both or manually disable them from starting up.

A colleague of mine working right now, told me it had happened again. When he now closed watchpoint on the display machine, he saw that it had opened up 5 other instances of watchpoint. Is this part of watchouts attempts to regain control or something? This must've happened overnight, because everything was fine when we left it last night.

Link to comment
Share on other sites

Sorry for spamming both this thread and the other one with this image, but alas - the error happened again even after uninstalling what I thought were the culprits (iums and mse) operating in the background.

As I gather from the thread about the minimized windows and latency bug, does changing from using the IP adresse to define the display to name help?


Addendum: I see now in the Network window that the display machine does indeed have a Computer Name - but we've always used IP. Changed each display now to the Computer Name instead. Lets see how that turns out.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...