Jump to content

Routed Watchout?


JohnHuntington
 Share

Recommended Posts

For our annual Gravesend Inn haunted hotel, we run two Watchout systems for two independent effects. I run each system in its own VLAN in our managed network, and then use inter-VLAN routing in order to control the two separate WO display clusters from Medialon Manager for the show. This ran great last year, here's a writeup: http://controlgeek.net/2012/3/17/managed-switchrouting-ethernet-infrastructure-for-the-graves.html I was a bit concerned about performance, but I even take WO time code back from the display clusters into Medialon to trigger lighting and other cues, and that works just fine through the router.

 

I needed to tweak the content, and came across something interesting. If I shutdown Manager, and run the WO production software on the show control machine, I have limited communications/functionality with the display machines. Specifically, if I go "Online" in the WO production software, the display machines will cue up to the top of the timeline. However, if I manually locate to a different point in the time, the display machines do not update. If I then "Update" from the production machine, the display machines will move to the right place in the timeline. But if I hit the space bar for play--nothing happens. Standby also doesn't seem to work.

 

This isn't a big problem since I can always tweak the content by running the production software from a laptop on the same VLAN--that worked fine last year. But I was wondering why this wasn't working.

 

My guess is that, when operating from the production software, some sort of multicast WO sync traffic is not making it through my router? I tried a turning on IGMP snooping on those three VLAN's but that didn't seem to work (I didn't have time to take that any further).

 

Any ideas?

 

Thanks!

 

John

www.controlgeek.net

Link to comment
Share on other sites

My guess is that, when operating from the production software, some sort of multicast WO sync traffic is not making it through my router?

Yes, that sounds likely. The sync beteween the computers use UDP multicast, while most other traffic uses TCP. Seems like your router lets TCP through but not the UDP multicast.

Link to comment
Share on other sites

Another possibility is a WATCHOUT production computer with multiple NICs. (like ethernet and WiFi on a laptop.)

Seems the TCP traffic routes correctly, but the UDP multicast goes out the wrong NIC.

You can quickly confirm this by disabling the second NIC and determining if normal operation is restored.

If it is, and both NICs are needed, re-order the NICs to get around this.

You could try this procedure ...

 

Navigate to Network and Sharing Center > Change Adapter Settings (or simply type ncpa.cpl in Run).

Next, hit Alt to bring up the menu and click Advanced > Advanced Settings....

Then, simply reorder your network connections on the Adapters and Bindings page

so that your WATCHOUT NIC is first.

 

A reboot may be required for the settings to go into affect.

Link to comment
Share on other sites

  • 6 months later...
  • 2 weeks later...

Would it be possible to add as a feature request the ability to specify a range of multicast addresses to be used?  Our networks are getting bigger, and more devices are using multicast, so being able to configure and manage that traffic is becoming important.

 

Thanks,

--D

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...