Jump to content

bug - refused to play timeline


Recommended Posts


I had a show with multiple clips in the timeline. It played perfectly for 2 days. The computers been rebooted between those 2 days. At the end of day 2. Arrowhead is position before the cue. 

I remember that I triple, quadruple check that I was clicked on the main timeline and that I was online and that I was not on standby mode

friday april 12 at 20h35

  • - I Press space bar - Nothing
  • press again, maybe I didnt fully press - nothing
  • I think, maybe the keyboard stopped working, I click with the mouse on the green arrow at the bottom of the main timeline - Nothing
  • I move the arrowhead else where, it moves but no files play on the production computer and on the display computer.
  • press space bar again multiple times. 
  • Try ctrl-D
  • try going offline (I can see the status window going from online to offline) then online (I can see the status window going from offline to onine)
  • nothing happens
  • try offline-online again. still does play
  • quit the application, reopen, everything works.

Missed the first 25% of the show( a 4min show) My client was unhappy, and the client of my client even more. I can't even reproduce the bug. It seems very random to me. 

never saw any error message.

The log show the same message error mxhscroll or something like that. See attachment

watchout version 6.2.2

Let me know if there is something I could provide to help you help me thank you



Link to comment
Share on other sites

  • Dataton Partner

It looks a bit like a fault on your production computer. Has it been tweaked (basic tweaks)? Which OS are you running?What sort of graphic card are you using on the production computer?

Pre-loading 12 timelines can put some work on the production computer since it needs to render all the content of the stage window at the same time while usually the graphic power of notebooks is not the highest.

If you have a lot of displays and maybe even more than one display computer, the display engine in WATCHMAKER has to do the work of the complete cluster to render the content.

A good way to handle this is to switch the stage window to show thumbnails only instead of videos in highest possible quality. Once the show is programmed it is usually not necessary to see the videos running in the stage window. This reduces the load on the production computer quite a lot.

The log files do not seem to show any information about the crash on April 12th. 

You could maybe check the events of the Windows log files. Maybe you'll find some hint in there.


Link to comment
Share on other sites

Thank you for your answer. The stage preview was in high quality for programming. that must be why. It's unfortunate that w-o cannot handle this error and just crash instead of maybe not allowing to get there. I only found this behavior while trying to reproduce the "not responding to play" issue(Which I was not able to reproduce).

windows 7, service pack1. The basic tweeks had been done. The show is done now, I don't have access the graphics card.

Now about the real issue. The playback not responding. I wish I still had access to the computer to get the event log of windows. I'll see if I can find a way to get it. Anything else I should be looking for that could be helpful finding the problem?

Thank you

Link to comment
Share on other sites

  • Dataton Partner

I've not seen WATCHOUT production crashing when too many videos had to be rendered. It usually slows down a lot and working with cues gets lagging. But the Windows protocols could show more information about the cause of your issues. Alex is pointing to an issue which usually happens when more than one NIC is active. In this case the production software will roll the timeline but the display computer will not react. In your case, the gui of the production software was blocked, wasn't it?

Link to comment
Share on other sites

Hi, I missed Alex answer. 

There are 2 network port and each computer (production and displays). Only one port on each computer had a network cable plugged in.

In my case, the production computer refused to roll any timeline. It was stuck at stop. I would click on the play button at the bottom of the timeline and I would see the button being pushed down, but it would return to a non-pressed state immediatly after the release of the mouse click / space bar.


thank you for your time

Link to comment
Share on other sites

  • 3 weeks later...
  • 2 weeks later...

Hi Wiesemann, 

I tried to replicate the bug right after the show that night. I was not able to make it happen again. I tried really hard. Redid the exact same steps that I did. It just never re-occured. It was a really weird bug. If I ever come across again, I'll update this thread.

thanks for your input

Link to comment
Share on other sites

  • 4 weeks later...
  • 1 month later...

I had a similar issue, that I eventually found the source of. Worked all day, show started, and production did nothing. Responded locally but not controlling displays. Restart production, works fine.  My cause?


I had a few elements that were HAP in free running loops, fairly short.  If left running, after a few hours, they started to bog down production very quickly at some point.  10 second loop would lock up after a few hours. I rendered a much longer version, and found it would go days without locking up.   It seems that after a certain number of iterations it would lock up.  It happened twice, so I systematically ran my elements one by one every night until I found the issue.  This was in 6.2.2 I believe. FWIW... 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...