Jump to content
Dataton Forum
TwoBeAss

Video stuttering for the first seconds

Recommended Posts

Hi there,

ive got a big problem with my playout machines (2x xeon, 64gb ram, win7 64bit, 2TB Raid with 3000mb/sec, nvidia m4000)

The problem is, that if i play back a movie (tested, TIFF and HAP) the first 1-2 seconds the video is stuttering, after this time its running smooth as expected (even if four outputs are used) but the first one or two seconds its like hell...

Same problem if i do a blend from one to another movie, the whole show is stuttering for two seconds if a new movie is starting...

 

Any hints for me to find the bottleneck ?

 

Thanks in advance,

TwoBeass

Share this post


Link to post
Share on other sites

Hi

 

I've experienced something similar. To avoid this effect I normally start the timeline, and immediately pause it for a second, and the continue. The issue is that the timeline is not online, until you play it. You can see the little red dot to the left. If it's solid the timeline is off. You could try to online the timeline, but don't play it. Play it after 4-5 seconds, and if you still experience the described issues, then the problem lies elsewhere.

 

Best regards Christian

Share this post


Link to post
Share on other sites

...

Same problem if i do a blend from one to another movie, the whole show is stuttering for two seconds if a new movie is starting... 

 

 

Hi

 

I've experienced something similar. To avoid this effect I normally start the timeline, and immediately pause it for a second, and the continue. The issue is that the timeline is not online, until you play it. You can see the little red dot to the left. If it's solid the timeline is off. You could try to online the timeline, but don't play it. Play it after 4-5 seconds, and if you still experience the described issues, then the problem lies elsewhere.

 

Best regards Christian

 

Not sure this is a' stop to run' transition issue, as he mentions it occurs on movie transitions in a running timeline.

 

OP, have you tried switching to manual preroll and increasing the preroll time on your movie cues?

 

Are you using a motherboard software RAID controller or a PCIe hardware RAID controller?

If MB, check your BIOS to be sure your hard drive controllers are running in the correct mode (AHCI, not IDE).

If this mode is wrong, all disc transfers may start with a delay.

Share this post


Link to post
Share on other sites

Hi,

Preroll is not the solution. If i increase the Preroll-Time, the lagging just starts a little earlier...

 

Ive got an Hardware Raid Controller (LSI Megaraid) but even if im using the Software Mainboard Raid Controller ive got the same Problem. I changed the Hard-Disk drives to be sure its not a Problem of them, but still no effect...

Im a little Idealess...

 

Could it be the processors ? Ive got two processors on each Mainboard with 12 Cores each but with a relative low Frequency at 2,2 GHz...

 

RAM is running at 2400MHz... Any Ideas ?

Share this post


Link to post
Share on other sites

Hi there,

ive got a big problem with my playout machines (2x xeon, 64gb ram, win7 64bit, 2TB Raid with 3000mb/sec, nvidia m4000)

The problem is, that if i play back a movie (tested, TIFF and HAP) the first 1-2 seconds the video is stuttering, after this time its running smooth as expected (even if four outputs are used) but the first one or two seconds its like hell...

Same problem if i do a blend from one to another movie, the whole show is stuttering for two seconds if a new movie is starting...

 

Any hints for me to find the bottleneck ?

 

Thanks in advance,

TwoBeass

 

Question is does this occur when the same files are tried on another machine?

 

I normally do not touch the following in BIOS using the manufacturer's default settings instead. However in your case, you may want to try the following in BIOS -

 

1. Disable Intel C-State

It is a processor power management technology defined by ACPI. Enabled, it detects the idle state of system and reduce CPU power consumption accordingly.

 

2. Disable C1E Support (if this option is available; it may not be available when Intel C-State is disabled)

This function when enabled reduces the CPU frequency and voltage for power-saving in halt state.

 

3. Disable EIST (Enhanced Intel® SpeedStep Technology)

This adjusts CPU voltage and core frequency dynamically. It can decrease average power consumption and average heat

production.

 

You can try 1+2+3, or 1+2, or 3 alone to see which combination can help solve your start play problem.

If none helps, then suggest you return the settings to original as your problem lies somewhere else.

 

Thomas Leong

 

Edit:

Additionally, in your Power Plan -

Control Panel > Hardware & Sounds > Power Options > select your exisiting Power Plan or create a new one > Change Advanced Power Settings > twirl down to  Processor Power Management > Minimum processor state > set to 100% if you do not want the processor to slow down when system is in idle state; the default is 5%.

Not sure of your dual Xeons' processor speeds, but perhaps setting it not to step down when idle may help in the first 1-2 secs of playback.

Share this post


Link to post
Share on other sites

Your WO server machine sounds like it has plenty of power to run many layers of video.

Is it clean of other software and properly tweaked?

Have you opened the chassis and check that all of your connections are secure?

Have you had this issue before on these exact machines?

Do you own these machines or are you renting?

Did you have try all of the WO recommended video codecs and did you get the same results of stuttering?

Have you tried a video that you know to work on another system? Does it stutter?

What is running on the timeline right before the video plays? Any big graphics or other video?

If you place a single video on a empty spot in the timeline does it stutter? If yes then it would seem as if it would be a hardware or software issue not a codec issue.

More info could help isolate the issue.

Share this post


Link to post
Share on other sites

Which version of WATCHOUT are you running? Any difference between HAP and HAP_Q?

 

Does it make any difference to disable threaded optimization in Nvidia's control panel? Make sure you close the control panel before testing since it polls the GPU which can results in additional stuttering.

 

//Miro 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...