Jump to content

Barco shutter control

Lacey Erb

Recommended Posts

We set up a Watchout 6 system with shutter control of a Baco HDX-W20 FLEX by sending a string cue.  It was working just fine until we changed control computers.  After transferring the show file to the new control computer it stopped working.  


The syntax and port information are all the same, but now we are getting a "Warning: Failed delivering data: Open" or "Warning: Failed delivering data: Close"


Port 43680  TCP

Open: $fe$00$22$42$00$64$ff

Close: $fe$00$23$42$00$65$ff


We are running Windows 8.1 on the new control computer.  The original control computer ran windows 7.   


We wondered about it being a firewall thing but changes to our firewall settings don't seem to change anything.


What am I missing?



Link to comment
Share on other sites


... It was working just fine until we changed control computers.  ... "Warning: Failed delivering data: Open" or "Warning: Failed delivering data: Close" ...


Your command is wrong I'm afraid. Don't know it by heart, have it somewhere in my documents. But, if you search the forum you will find a previous post where the correct command it stated.

Good luck!




Hmm, I assumed since it was working with one production computer, it was not a message issue.


Pretty sure the string itself will not matter if there is not a successful conneciton first.

Link to comment
Share on other sites

The command strings and syntax seem correct. I'd connect up the Win 7 Prodn PC again and try. If successful, then it would seem that Win 8.1 has a problem.


Before I made the upgrade from 8.1 to Win10, I did have some problems with my 8.1 via LAN despite all the security and sharing settings that I usually make to give all my connections full read/write permissions. Never found the bug/solution. With the upgrade to Win10, the same connections 'saw' and permitted read/write to and fro all the time. Never had Firewall enabled in all my connections.


Thomas Leong 

Link to comment
Share on other sites

Lacey Erb,


Is your 8.1 Production PC a laptop or desktop?

If a laptop, are there any manufacturer's bloatware installed? Shot in the dark then : Uninstall one by one and try sending the string to the Barco between each uninstall. One of the bloatware may be the culprit.


Thomas Leong

Link to comment
Share on other sites

The warning messages indicates the IP address of the projector can't be reached. If you're running from the production computer (can't tell from your description), you may instead try connecting to the projector using a telnet client running on the same production computer. That will most likely exhibit the same problem, allowing you to troubleshoot the connection independently from WATCHOUT. Windows has a telnet client built in (although it may need to be explicitly enabled in the "Programs and Features" control panel).



Link to comment
Share on other sites

The original windows 7 production computer has been installed on another show so I am not able to test it on that machine again.  But it was definitely working there.  


The windows 8.1 is a laptop.  Bloatware is certainly possible.  There hasn't been time to troubleshoot via telnet, but its a good idea.  


The show opens tonight, so for this one we are going to stick with our workaround of using the Barco browser controler from a separate computer.  Not elegant or ideal but functional.  


We have 2 (if not 3) other shows this year using Watchout and the Barco projectors, so we will continue to work on this one.  


Thanks for your help.  



Link to comment
Share on other sites

  • 2 years later...

Doubt that there is a fix needed since sending TCP/IP and UDP works fine from WATCHOUT.

If it doesn't work for you, you should check whether the computer blocks something or whether there is an issue in the network or with your strings. Having programmed show control systems for the last 30 years, my first functionality test starts with a program like PUTTY. It merely does the same what WATCHOUT would do but it is easier to find problems in the first place.

If PUTTY does not work, check what's blocking the port!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...