Jump to content
Dataton Forum

HAP import/playback errors on Win10 Production Laptop


Recommended Posts

Hi,

I'm in the process of setting up a new production laptop, and I'm encountering errors when trying to import & playback HAP video files in Watchout.

When I tried to add HAP media to the project, I got an error message: 'Error: Not recognized as a media file'. When I opened an older project, which already has HAP media imported, playback results in a 'Quicktime error -2095'.

I've tried a 'repair' installation, as well as a complete removal and re-installation of Watchout 6.6.4. I also tried installing Quicktime, but that just results in a 'Quicktime Error -8961' error (as mentioned here: https://forum.dataton.com/topic/6365-hap-q-from-avf-batch-converter-quicktime-error-8961/) when attempting playback, so I uninstalled Quicktime and am back to a barebones Watchout installation.

This is a new installation of Watchout 6.6.4 at the root of the C drive. Other video files with h264 and Mpeg2 codecs are importing and playing back fine in Watchout. I started to have doubts about the Hap encoding, so I encoded some test files in HAP, HAP-Q, and HAP-Alpha flavours, using Adobe Media Encoder and AVF batch converter. All of the HAP files play with no errors in VLC, Disguise and Notch, but I still get an error when I attempt to import them into Watchout. I wondered whether there is a possible conflict with the other software (Disguise, Notch) but they are cohabiting fine with Watchout on another Win10 machine. That machine also has several versions of Watchout installed (via the zipped installation folder method) and all seem to be working OK. As an aside, on the other laptop, I notice that HAP files encoded with Adobe Media Encoder show generic file icons in the Media window (but playback is fine), while those encoded with AVF batch converter show as thumbnails.

The laptop is a new MSI machine running Windows 10 Pro (20H2 Build 19042.789) with a Nvidia RTX2070 Super card (driver DCH 461.40). I've deactivated many of the Windows services but, since this is a production machine, I haven't applied everything in the display machine tweaking list. I'm pretty sure there are no dodgy codec packs installed.

So it looks like it's something related to this new machine - if anybody has any ideas or pointers to the problem, I'm all ears...

Link to post
Share on other sites
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...