Jump to content

Recommended Posts

Dataton Support,

We are experiencing issues with Dynamic Image Server 5.5 (as packaged with Watchout 5.5.1). When adding a dynamic image to the production computer, the production computer reports the following error:

From Dynamic Image "<media name>" of Media List, <timestamp>
Error: Server Timeout

In addition to receiving this error message, the requested image blinks in the Dynamic Image Server window. The file requested is jpg format.

System Specifications:

Windows 7 64-Bit Enterprise, Service Pack 1
Intel i5-3570k (Image Server)
Intel i7-3770k (Production and Display Computer)
Gigabyte Z77X-D3H Motherboard
Nvidia 640GT Display Card (Image Server and Production Computer)
AMD 7970 Display Card (Display Computer)

Datapath Vision RGB-ES1 Capture Card (Production and Display Computer)

Additional Information:
Windows firewall disabled
All computers have static-assigned IP addresses in the same subnet
Production and Display computers function normally otherwise

Steps Taken:
Verified file path is correct (based on blinking behavior on Image Server, server and file path should be correct)

Verified Production computer can load the same image file directly; independent of the Image Server

Attempted to use different file and file format

Reboot all computers

Uninstalled / reinstalled Watchout on Image Server as suggested in other threads reporting similar issue.



Please let me know if I can provide any additional information.  Thank you for your help!





Link to comment
Share on other sites

  • Moderator


All computers have static-assigned IP addresses in the same subnet



While static IP is ok, it is best to avoid entering the IP in the Display configuration dialog.

Possibly you are using names, not clear from the description.

This is a change from all versions prior to 5.5

We have observed anomalous behavior when using IP addresses in

watchmaker's display configuration w/ 5.5+.

Best to rule that out first.


Use the new Computer Name feature for the Computer: designation

in watchmaker's Display configuration dialog.




The names are assigned in watchmaker v5.5+ Network window (found in the Window menu).

When open the window is titled "Display Computers Found on Local Network".


Once assigned, the name remains with the display computer

until somoene uses watchamker's network window to change them.




The name is shown in watchpoint 5.5+ initial logo screen.

The sample shown is configured with a fixed IP.



Link to comment
Share on other sites

  • 2 weeks later...



Thank you for the prompt responses.  The system is in-use for extended hours due to holiday scheduling, but I will try your suggestions as soon as there is some down-time. 


I have some additional information which may provide some insight into the problem. 


First, I attempted to use the Dynamic Image Server with another Watchout system in the building.  This worked without issue, and the image displayed correctly.  We did not experience any of the blinking issues.  This Watchout deployment is on the same network, and it is configured in the same manner (using IP addresses; not names).  This system is running Watchout 5.5 (not 5.5.1) on both the Production and Display computers.


Second, the Dynamic Image Server system drive was cloned from Production computer of the Watchout system that cannot connect to the DIS.  After the image was deployed, the computer name and IP address were changed.  I uninstalled / reinstalled Watchout on the DIS, but I did not clear the registry of all entries for Watchout.  Is is possible that a pre-existing registry entry would cause the symptoms that we are experiencing?


Thanks for your help!




Link to comment
Share on other sites

  • 2 weeks later...



I ran WireShark on both the Image Server and the production computer while adding dynamic media.  I see UDP packets going both directions between the two computers.  Based on this test, UDP is making it through the network.  Also, the same Image Server works normally with our other Watchout 5.5 system. 





As you recommended, we have changed the display computer reference from IP address to name. 




The problem persists.  To verify that the issue is not related to the cloning process, I have gone through the uninstallation process again.  This time, I wiped the registry of any reference to Dataton and Watchout.  Any suggestions on how to resolve this issue would be greatly appreciated.



Link to comment
Share on other sites



I reverted to the on-board graphics card in the DIS.  The problem persists.




We have attempted several additional troubleshooting steps.  Here's what's new:


The DIS works correctly with a different Watchout 5.5 system (System B), but does not work with the Watchout 5.5.1 system (System A) for which it was intended.  In order to determine if 5.5.1 has issues with DIS, we updated the 5.5 system (System B) to 5.5.1.  The DIS continues to work correctly with the updated system (System B).  However, it still does not work with the intended system (System A). 


Reinstalled Watchout 5.5.1 on the Watchout Production computer (System A).  Problem persists.


In order to determine if the issue was caused by the cloning process used to deploy the system, we re-built the DIS from scratch.  We installed Windows 7-64bit, device drivers, Quicktime, and Watchout 5.5.1.  The firewall was disabled.  The problem persists.





I agree with Mike's conjecture that UDP packets aren't making it into Watchout.  I see UDP packets (with Wireshark) that contain the file arriving at the computer (packet header has file name clearly identified), but Watchout does not recognize that the data is being received.  Is is possibly a data timestamping issue?  I'm going to check BIOS clocks on all of the machines.  There has to be a valid reason why Watchout does not see the data. 


Any other thoughts on what would impede the flow of UDP to the application? Thanks for your input gentlemen!

Link to comment
Share on other sites

Clarification - The WYSIWYG editor made some changes to my previous post.  The smileys were supposed to be System B, but the combination of B and ) appears to be an escape sequence for emoticons. 



I checked the system time on all computers.   They are all set fairly close.  Also I ran Wireshark again and saw the UDP packets arriving at the Production computer.  Any suggestions on what to try next?

Link to comment
Share on other sites

I have a content creator that can only build video in Flash. As they are large files, the export process to a standard video codec is painful and so far has not been reliable.


I'm attempting to use the DIS to serve the SWF files as a workaround. I can get the SWF to load in the DIS and appear correctly on the display machine, but it doesn't play. I've tried passing play=true in the parameters to the SWF file, but no change.


Any trick there? When I open the same SWF via a web browser or flash player, it plays fine. Does DIS pause SWFs by default? 



Link to comment
Share on other sites

"In order to determine if the issue was caused by the cloning process used to deploy the system, we re-built the DIS from scratch.  We installed Windows 7-64bit, device drivers, Quicktime, and Watchout 5.5.1.  The firewall was disabled.  The problem persists."


Me thinks you have gremlins in System A!!!


According to Gary from Cool Illusions, when I visited him, his 'blinking problems' went away when he upgraded from XP to Win 7 on his particular system.

reference post: http://forum.dataton.com/topic/1027-image-server-on-watchout-55/?hl=%2Bdynamic+%2Bimage+%2Bserver



So perhaps a clean install is required in your case (wipe partition, etc...or use a new hard-disk to install the system and Watchout).


good luck!

Thomas Leong

Link to comment
Share on other sites

  • 2 weeks later...

Dataton Support,


We wiped the production computer clean and installed the following applications:


Windows 7 64-bit Service Pack 1



Watchout 5.5.1


We installed the following Windows updates (as required by driver installation):





Firewall is disabled.


The image still blinks on DIS and does not display on the production computer.  


To recap, we have now wiped and rebuilt both the DIS and production computers.  DIS will work with a different Watchout 5.5 system, but will not work with the 5.5.1 system.


Any suggestions or recommendations would be greatly appreciated.  Thanks!

Link to comment
Share on other sites

  • 4 weeks later...

I know this in not the answer you´re looking but...

Do you really need the DIS. Did you try to use an HTTP server instead ?


I´m using Nginx to stream 22 pictures to 22 watchpax at the same time.


From my experience with DIS and Nginx the big difference is that DIS is constantly updating the display , so if you replace the media file in the DIS the display will be updated automatically and creating a lot of traffic in the network. When using the HTTP server the media is only streamed once when the Cue is loaded in the time line, meaning if you need to replace the source media, in order to update the display you need to re-run the Cue.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...