Jump to content

Recommended Posts

I have a watchout version 6.6.5 running with NDI input.  When watchout display (Watchpoint) starts, it seems to use the wrong IP address.  Is there a way to force it to use a different NIC in the autostart.txt?

 

I didnt see this documented.

I Can connect to the display computer, but it no longer advertises in the "display computers found on network" box anymore.

 

Thanks

Jason

Link to comment
Share on other sites

6 hours ago, jaygrovr said:

… Is there a way to force it to use a different NIC in the autostart.txt? …

No.

WATCHOUT will use the first NIC in Windows NIC priority. To change the NIC used by WATCHOUT, change the NIC priority in Windows.

Link to comment
Share on other sites

  • 3 weeks later...

So I set the priority of my desired NIC to be used for watchout control to 1, and I set the other nic to 2, and when I rebooted it took the IP address of the priority 2 nic.  Any reason why that would have happened?  I had to keep the second nic unplugged and bootup the machine to make it take to the NIC I wanted it to.

 

Any thoughts?

Link to comment
Share on other sites

  • 2 weeks later...
On 8/29/2022 at 5:37 AM, jaygrovr said:

So I set the priority of my desired NIC to be used for watchout control to 1, and I set the other nic to 2, and when I rebooted it took the IP address of the priority 2 nic.  Any reason why that would have happened?  I had to keep the second nic unplugged and bootup the machine to make it take to the NIC I wanted it to.

 

Any thoughts?

The comments about NIC order refer to watchmaker. 

Good question about the impact of NIC order on watchpoint. Will look into that.

Link to comment
Share on other sites

watchpoint's NIC selection is not related to Windows NIC priority. Apparently something in the registry determines the NIC selection when more than one active NIC is available when watchpoint starts. It would appear your only choice is to both use the NIC watchpoint automatically selects AND set that NIC as first in Windows priority when more than one active NIC is available. 

Link to comment
Share on other sites

Jim I appreciate the response, but that still does not indicate how I can force the software to use one nic over another.  I have set the metric of the desired nic to 1 and the undesired nic to 5 and 10, and it still boots using the undesired nic.  If you can find out what items I can change in the registry to force it the same way everytime, it would be appreciated.

Link to comment
Share on other sites

I dont want to do that unless I know that is the issue.  I find it hard to beleive that both nics are not ready when the pc starts up.  They both have link lights as soon as the power is turned on.  I need a better more reliable way to prioritize these nics.

 

Jason

Link to comment
Share on other sites

11 hours ago, jaygrovr said:

I dont want to do that unless I know that is the issue.  I find it hard to beleive that both nics are not ready when the pc starts up.  They both have link lights as soon as the power is turned on.  I need a better more reliable way to prioritize these nics.

 

Jason

Hi Jason, 
Believe it or not:
1.Watchout can not select NIC
2 Watchout can be loaded before the network is ready
3.OS need some time to load drivers/settings....and also network.
4.link lights on/blinking does not mean network is ready in OS/Watchout


If you believe my above "experience", you can try
1. set the Watchout NIC Interface metric to 1
2. set ~15seconds Delay start for Watchout Display.
or manually start Watchout Display instead of "startup".
The delay command is made for waiting "something"(network is one of something) to be ready before Watchout Display start.  
3. test it

I could be wrong. but without trying, you never know.
"Trial and error"

 

or Just Try to run a simple ipconfig on startup. you will see the network is ready or not. then you can choose what to believe.

 

 

Link to comment
Share on other sites

I must run two nics because of the control system and IT limitations that were put on the system.  We have an NDI feed that is coming from an entirely different subnet, and I cannot mix multicast/broadcast which NDI uses with the secure network that is controlling the watchpoint playback system.  This request seems to be a dead end, and if watchout/dataton cannot figure out how to prioritize its Nics if you have more than one, then this product is pretty useless to me at this point and I will look for other options.  For a piece of software that requires a network connection, you should and must be able to force it which NIC it should be using for remote connection, since that is so damn important.

Link to comment
Share on other sites

Hi Jason,

I used double NIC many times with Windows priority, specially when using DANTE VIRTUAL SOUND CARD, with no problems and I always use de -Delay command to be sure all drivers and specially network are correctly set,  I normally use 10 seconds but you always need to check if you need more to be sure all is ready.

But anyway, you are right, you should be able to select which NIC to use in Watchout, hope they include it in the next version.

Best regards,

Quim

Link to comment
Share on other sites

On 9/14/2022 at 5:23 PM, jaygrovr said:

... They both have link lights as soon as the power is turned on.  ....

OK, that indicates

  • a valid network cable / hardware / electrical connection
  • Powered off, may indicate ready for Wake-On-LAN.

It does not tell you if or when the OS driver is loaded and initialized.

Link to comment
Share on other sites

Ok I tried the delay, its still using the wrong nic.  I have set delay for 30 seconds.  I am going to increase to 2 minutes to see if that makes any difference.  Metric on card I want to use is 1 and metric on the other card I dont want to use is 50.  I have changed it to 2 minutes and I do see it counting down on the screen.  ITs still not doing what I need.

 

Another note, the nic that the software is binding to is a PCI express NIC that is 10gig.  I know it doesnt matter, but the NIC I want to use for control is on the motherboard.  Maybe there is some setting on the PCI express NIC that I need to set to make it wait?

 

Any other ideas?

Link to comment
Share on other sites

i also tried the task scheduler to delay startup for an additional minute, and wp.exe is still selecting the wrong nic.  The only way I can make this work is to disconnect the cable from the wrong nic, bootup the computer and then plug it in.

 

Any other ideas?

Link to comment
Share on other sites

Hi again Jason.

Watchout can not select NIC.
It will pick the first one(it define by the OS) when starting.

If delay more than 15s, is NOT normal.
network seldom take more the 10seconds to be ready.

You should check something else.

Don't run Watchout on startup.
run IP config on startup, see if you can see the "correct" nic are ready.

and check your network settings.
and how's your IP setting for both nic?
and how do you know it is on the wrong nic? by IP address or?

Link to comment
Share on other sites

i know its the wrong nic becuase on the display output its showing the incorrect IP address to use for communication.  It says "Display 1 - x.x.x.x"

SO what am I looking for in ip config then?

IP settings for the nics are 10.10.5.40 and the incorrect one is 192.168.100.100  both class C.

I am confused what I am looking for.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...